Neck Pickup Buzzing Problem - Jemsite
Archived Topics and Common Questions Common topics/questions are archived here. You can reply but not start new threads here. New visitors please search the forum for a question possibly already discussed.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-01-2011, 01:06 AM Thread Starter
 
Join Date: Oct 2010
Location: Malaysia
Posts: 6
Neck Pickup Buzzing Problem

Why does my guitars neck and bridge pickups buzz when plugged into the amp? The bridge pickup buzzes very softly and is almost undetectable, but the neck pickup buzzes very loudly! I've tried different guitars on my amp and they were all silent, so my amp is ok,I think. I've also tried different cables but it still buzzes.

Please help!!!!!!
cooper9797 is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Buzzing problem... bhuether Pickups & wiring 1 01-24-2009 11:39 PM
RG Prestige 1620X buzzing problem ANT All Other Guitars (including Prestige) 1 04-17-2006 03:26 AM
Help me please! Buzzing problem hararge Pickups & wiring 7 10-09-2005 01:47 PM
Buzzing problem in a particular spot caprile Tech: Setup, Repairs and Mods 10 04-19-2003 10:23 PM
Low E buzzing problem EXCrosslink Ibanez JEM, UV, JS & Other Signature Models 10 04-12-2003 01:11 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome