RG550 Tremolo Arm Insertion Problem - Jemsite
Archived Topics and Common Questions Common topics/questions are archived here. You can reply but not start new threads here. New visitors please search the forum for a question possibly already discussed.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-09-2011, 06:26 PM Thread Starter
 
Join Date: Feb 2011
Location: Oklahoma
Posts: 12
RG550 Tremolo Arm Insertion Problem

Hey Ibanez experts,
I was wondering if someone could help me with a problem.
So i have this RG550 wit the 1991 standard RG550 floyd rose action.
At first, the trem arm was just very loose, as all old RG's are, so i took it to a repair shop and they tightened up everything in the trem arm socket and when they gave it back to me they said everything was fine now, but the only problem is that the arm will still be loose because of the old bushings or whatever. i dont really care right now. i read about some plumbers tape trick on these forums one time, so ill try that later.
PROBLEM: the trem arm wont go into the socket. even if i push hard, it wont go in. is there something that i have to unscrew or align? the dude fixed it so its gotta go in somehow.
Please, help me.
Tom Stegeman is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-09-2011, 07:38 PM
Banned
 
Join Date: Dec 2008
Location: Houston, TX
Posts: 9,291
Reviews: 98
Re: RG550 Tremolo Arm Insertion Problem

Welcome aboard! That is not a Floyd Rose--it's an Ibanez Edge. For most of your Ibanez setup and maintenance tutorials, please go visit Rich's site ibanezrules.com
We also have a search feature that you should use, as most of these questions have been answered before.

Here's the link to what you need
http://www.ibanezrules.com/tech/setup/index.htm



AlaskaBat is offline  
post #3 of 5 (permalink) Old 05-20-2011, 07:47 PM
 
Join Date: May 2011
Location: NC, USA
Posts: 2
Re: RG550 Tremolo Arm Insertion Problem

Tom, my RG550 came with some small plastic or nylon bushings that replace the ones on the tremolo bar when they wear out. I replaced them once in 20 years and just ordered some new ones.
me109nc is offline  
post #4 of 5 (permalink) Old 05-21-2011, 02:00 AM
Banned
 
Join Date: Dec 2008
Location: Houston, TX
Posts: 9,291
Reviews: 98
Re: RG550 Tremolo Arm Insertion Problem

Rich has tons of them!



AlaskaBat is offline  
post #5 of 5 (permalink) Old 08-05-2011, 03:45 PM
 
Join Date: Aug 2011
Location: United States
Posts: 6
Re: RG550 Tremolo Arm Insertion Problem

I'm having a similar issue on my RG5SP2. I've tried the steps on the IbanezRules site to no avail. It actually seems like someone has put something down the hole. It didn't have a trem arm when I bought it, so maybe this issue explains that. Hopefully I can get this taken care of.
jasvanek is offline  
 

Tags
bar , problem , rg550 , tremolo , wammy

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZR tremolo problem Tomm89 All Other Guitars (including Prestige) 17 04-13-2010 02:53 AM
ZR Tremolo Problem Shep4 Tech: Setup, Repairs and Mods 5 04-14-2009 11:22 PM
Tremolo problem shreddingjoris Tech: Setup, Repairs and Mods 8 12-08-2007 07:34 AM
Lo Pro Tremolo problem Pikaciao Tech: Setup, Repairs and Mods 3 11-13-2005 01:39 PM
need help with a problem with my tremolo! Omso All Other Guitars (including Prestige) 9 09-12-2004 01:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome