Forearm problem, kinda freaked out - Jemsite
Off-topic / Miscellaneous Talk about miscellaneous stuff off-topic and not related to music, guitars or bands. No music, gear or anything guitar related here please.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-11-2006, 04:08 PM Thread Starter
 
Join Date: Jul 2005
Location: racine, WI
Posts: 1,499
Reviews: 7
Forearm problem, kinda freaked out

So yesterday I was playing guitar for maybe 30-40 minutes and I stopped to go do something quick. Once I started to stand up I noticed my right forearm locking up and it felt like I was being electracuted in my forearm aswell. Has anyone had this before? Could it be a vitamin deficiency or something? I know it can't be tendonitis because when I play my picking hand isn't tensed up nor is any of my arm. Thanks for any help guys...
brothersnowgone is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-11-2006, 05:21 PM
 
Join Date: Mar 2006
Location: Westmidlands, UK
Posts: 926
Re: Forearm problem, kinda freaked out

Sounds like RSI to me.
ibanez2005 is offline  
post #3 of 6 (permalink) Old 07-11-2006, 05:22 PM
 
Join Date: Mar 2006
Location: Westmidlands, UK
Posts: 926
Re: Forearm problem, kinda freaked out

I find too when you play sitting down, you clench your body up, try to relax and find a different way of sitting when you play.
ibanez2005 is offline  
post #4 of 6 (permalink) Old 07-11-2006, 05:31 PM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,238
Reviews: 120
Re: Forearm problem, kinda freaked out

This could be bad. I'm still sporting an injury (over a year now) to my forearms and wrists from working on computers at a badly set up desk. Do you work in an office at a computer? If so you should get your desk setup checked out by a workplace person and make sure is all ok. If you are still feeling pain regardless of if it's from work -related stuff or just guitar get it checked out now.
LonePhantom is offline  
post #5 of 6 (permalink) Old 07-11-2006, 05:37 PM Thread Starter
 
Join Date: Jul 2005
Location: racine, WI
Posts: 1,499
Reviews: 7
Re: Forearm problem, kinda freaked out

Yeah I don't work in an office, but I am on my computer often. Could it be how I'm using the mouse or how I'm typing? thanks guys
brothersnowgone is offline  
post #6 of 6 (permalink) Old 07-12-2006, 06:38 AM
 
Join Date: Jun 2006
Posts: 1,614
Re: Forearm problem, kinda freaked out

Quote:
Originally Posted by brothersnowgone
Yeah I don't work in an office, but I am on my computer often. Could it be how I'm using the mouse or how I'm typing? thanks guys
Yes, it could be both.

You should go get it checked out by a doctor!

~ Katrina
katrina is offline  
Reply

Tags
playing guitar

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with 2003 7Vwh JEM, Possibly New Edge Pro Trem Fault leonard deroma Ibanez JEM, UV, JS & Other Signature Models 89 06-18-2007 10:57 AM
Saddle problem on Edge Pro ThomasBJ Tech: Setup, Repairs and Mods 11 04-12-2005 02:05 PM
JCM2000 DSL100 volume swell problem Joshka Gear, Equipment, Recording & Off Topic 40 04-14-2004 05:49 AM
I've finally got the RG2820...however, one problem..advice? triaxis All Other Guitars (including Prestige) 11 11-16-2003 09:06 PM
Input Jack - ... anyone else got this problem? Fabe Tech: Setup, Repairs and Mods 0 03-28-2002 06:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome