I solved the Lo-trs II problem in JEM555 - Jemsite
Ibanez JEM, UV, JS & Other Signature Models For discussion of Ibanez JEM, Universe and JS (Satriani) guitars only.

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 08-26-2001, 03:42 AM Thread Starter
 
Join Date: Aug 2001
Posts: 36
I solved the Lo-trs II problem in JEM555

I don't tell nothing specific yet, but I'm so excited that I have to share this feeling with you. Yesterday I broke up my JEM555's Lo-trs II and simulated the vibrato with it. The fault was oblivious. I took my JEM555's Lo-trs II with me in job and show it how we take care thinks in here (I'm in job right now, I work with extremely high mechanics and electronics). There is one thing that I can promise ! The arm is very tight and moves smoothly. And 'cause I have to test it before, the tune thing is something I will tell you tomorrow.... Yet intersted ?
MorbidDream is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 08-26-2001, 04:58 AM
 
Join Date: Apr 2001
Location: Reading, UK
Posts: 848
I solved the Lo-trs II problem in JEM555

yep, still interested.
BTW, it's sunday. You don't have to go to work today
SalemB is offline  
post #3 of 11 (permalink) Old 08-26-2001, 05:14 AM Thread Starter
 
Join Date: Aug 2001
Posts: 36
I solved the Lo-trs II problem in JEM555

--BTW, it's sunday. You don't have to go to work today

Yeah.. I don't have to, but I have to pay my new car and Rg550bk... :-) I'm from Finland and it's normal to do work in weekend... If you got ebough job to do and will to it.

I have to say one thing !! Everlasting same s**t, but I believe that JEM7*** are all better... But my Jem555 does just fine for me... Factory setups were from deep...
But after many hours and probably this modification.. It'll stay tuned..
MorbidDream is offline  
post #4 of 11 (permalink) Old 08-27-2001, 12:18 AM Thread Starter
 
Join Date: Aug 2001
Posts: 36
I solved the Lo-trs II problem in JEM555

It worked. 555's arm was very tight, but I think tune is something that you can't improve. Edges are sooo fat..
I'll try to find easier way to do the same thing that I did with expensive machines, so everyone could be modify their trs-II in home with basic tools.

I have also GOTOH's tremolo and that didn't also fix the tune problem... It's the edges... Just have to purchace new bridge.
MorbidDream is offline  
post #5 of 11 (permalink) Old 08-28-2001, 12:46 AM
 
Join Date: Jul 2001
Posts: 548
I solved the Lo-trs II problem in JEM555

What was wrong with the edges? I have a Jem555BK and i'm going to be replacing the Lo-TRS II with a Lo Pro Edge. It'll need a route but i'm ready for that. Also i'll be replacing the frets to 6105's and the jack to a proper. It'll pretty much be a 77 with EVOlutions. Correct me if i'm wrong.
YngVaiTriani is offline  
post #6 of 11 (permalink) Old 08-28-2001, 12:19 PM
 
Join Date: Dec 2000
Location: Ottawa, ON
Posts: 739
I solved the Lo-trs II problem in JEM555

Quote:
Quote: from YngVaiTriani on 12:46 am on Aug. 28, 2001
It'll pretty much be a 77 with EVOlutions. Correct me if i'm wrong.
You're wrong. It will be a 555 with a fret job, an Edge trem and a new jack. It still will not be worth as much as a used 77 Jem.
Jimi D is offline  
post #7 of 11 (permalink) Old 08-28-2001, 06:28 PM
 
Join Date: Jul 2001
Posts: 548
I solved the Lo-trs II problem in JEM555

JIMI D - I don't care what the name of the guitar is... I care how it performs and sounds... and i've played a 77FP. A good 555 with a Lo Pro, new jack and 6105's would perform the same as a 77 with EVO's.
YngVaiTriani is offline  
post #8 of 11 (permalink) Old 08-28-2001, 10:35 PM
 
Join Date: Dec 2000
Location: Ottawa, ON
Posts: 739
I solved the Lo-trs II problem in JEM555

Look Yng, I'm not the guy who's running around saying "my 555 with x & y is as good as a Jem 7" in multiple threads on the board... I really don't care what you play, but as far as I'm concerned, you could gold plate a 555 and it will still be worth less than a good RG550... basically, me thinks thou dost protest too much.
Jimi D is offline  
post #9 of 11 (permalink) Old 08-28-2001, 11:28 PM
 
Join Date: Jul 2001
Posts: 548
I solved the Lo-trs II problem in JEM555

Well alright then... i'm talking purely of facts... I know i'm right so whatever man.
YngVaiTriani is offline  
post #10 of 11 (permalink) Old 08-29-2001, 12:26 AM
 
Join Date: Jul 2001
Location: Buena Park CA
Posts: 33
I solved the Lo-trs II problem in JEM555

No you're not...
pharaoh is offline  
post #11 of 11 (permalink) Old 08-29-2001, 12:47 AM
site founder 0% owner
 
jemsite's Avatar
 
Join Date: Nov 2000
Location: NJ - USA
Posts: 11,480
Reviews: 1
I solved the Lo-trs II problem in JEM555

discussion over.
jemsite is offline  
Closed Thread

Tags
edge trem , pro edge

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New UV mystery solved? 123ahull Ibanez JEM, UV, JS & Other Signature Models 22 02-02-2013 03:35 PM
2nd UV mystery solved? 123ahull Ibanez JEM, UV, JS & Other Signature Models 58 01-06-2013 11:29 AM
Jem555/Bandit112/Gt-8 Problem j3yps Ibanez JEM, UV, JS & Other Signature Models 7 05-22-2008 11:44 AM
Edge III Mystery... Solved? eclecticmage Tech: Setup, Repairs and Mods 47 10-22-2006 12:08 PM
lo trs 2-problem solved johan15 Ibanez JEM, UV, JS & Other Signature Models 2 05-08-2002 01:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome