JEM77P - Pickguard trouble - Jemsite
Ibanez JEM, UV, JS & Other Signature Models For discussion of Ibanez JEM, Universe and JS (Satriani) guitars only.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-05-2006, 02:09 AM Thread Starter
 
Join Date: Apr 2004
Posts: 72
JEM77P - Pickguard trouble

Hi,

I've just go a mint JEM77FP 15th anniversary.

I am experiencing som weird things with the pickguard, and is wondering if it's normal. Where the screws are mounted, there are a small area around the screw, between the guard and the body, that almost seems like it has a liquid or something floating in between. I'm sorry if it's a confusing description, but It's really hard to describe it.

Anyway, has anyone else experienced this?

I tried removing the guard and wiping it, but it didn't really seem to have any effect.
Integrum is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-05-2006, 02:14 AM
 
Join Date: Sep 2005
Location: Sydney Australia
Posts: 2,049
Re: JEM77P - Pickguard trouble

..... and for tech/maintenance questions, the usual answer - go to Rich's site and look up the article on cleaning a guitar..... to shortcut that a little, it's a slight greasiness between the body and the pickguard - if you back the screws off just a fraction the little glob usually disappears.
David McCarroll is offline  
post #3 of 7 (permalink) Old 10-05-2006, 10:34 AM
 
JJEMMER777's Avatar
 
Join Date: Feb 2005
Location: Thornton, CO
Posts: 8,373
Re: JEM77P - Pickguard trouble

Quote:
Originally Posted by David McCarroll View Post
..... if you back the screws off just a fraction the little glob usually disappears.
Yep - works every time
JJEMMER777 is offline  
post #4 of 7 (permalink) Old 10-05-2006, 11:56 AM
 
Join Date: Jan 2006
Posts: 46
Re: JEM77P - Pickguard trouble

Beat me to it.
Had the same 'problem' on my 770DX. Loosen the screws.
StTan is offline  
post #5 of 7 (permalink) Old 10-05-2006, 03:02 PM Thread Starter
 
Join Date: Apr 2004
Posts: 72
Re: JEM77P - Pickguard trouble

That solved the problem, but isn't really 100% satisfied with the feeling of knowing that the screws aren't tightened "properly"

I guess I wiill learn to live with it
Integrum is offline  
post #6 of 7 (permalink) Old 10-05-2006, 03:08 PM
 
JJEMMER777's Avatar
 
Join Date: Feb 2005
Location: Thornton, CO
Posts: 8,373
Re: JEM77P - Pickguard trouble

Just back them out "just" enough so that the contact spots disappear. It's only a pickguard. You don't need the the screws torqued down

It'll still be snug.
JJEMMER777 is offline  
post #7 of 7 (permalink) Old 10-05-2006, 06:46 PM
 
Join Date: Aug 2003
Location: Odense S, Denmark
Posts: 9,952
Re: JEM77P - Pickguard trouble

Quote:
Originally Posted by JJEMMER777 View Post
Yep - works every time
+1

Regards

André



fettouhi is offline  
Reply

Tags
david mccarroll

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clear Pickguard shielding, QUICK HELP! Gex Pickups & wiring 7 06-02-2006 07:27 PM
What pickguard fits? Speedica All Other Guitars (including Prestige) 4 11-09-2005 08:04 AM
Jem 90th metal replacement pickguard philzeta Ibanez JEM, UV, JS & Other Signature Models 12 07-20-2003 11:15 PM
pickguard 90th vs UV777PBK,7DBK & 7BSB tony777 Ibanez JEM, UV, JS & Other Signature Models 1 06-12-2003 10:02 AM
Disappointed with pickguard - Jeannies Scoff X Tech: Setup, Repairs and Mods 3 03-26-2002 12:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome