JEM7V Trem Problem - Jemsite
Ibanez JEM, UV, JS & Other Signature Models For discussion of Ibanez JEM, Universe and JS (Satriani) guitars only.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-12-2010, 02:50 PM Thread Starter
 
Join Date: Jul 2005
Posts: 1
JEM7V Trem Problem

Hi Guys,

I have Ibanez Jem7V which I purchased from new back in 2003, however I am having a little problem with my Lo-Pro trem unit.

The trem is a push in version, however at the surface, where you insert the arm, there is a sort of inner ferrule which looks like a circle with 2 slits cut out of it opposing sides.
For some reason, this ferrule now seems to want to rotate as well when the trem arm is rotated. This is causing the trem arm to pivot in the slot making accurate trem usage and the new replacement trem arm bushes I put in useless.

Can you tell me what I can do you rectify this?? Is it just a matter of tightening it or something more intricate?

Cheers

Baz
bazman1uk is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-12-2010, 04:42 PM
 
Join Date: Sep 2009
Location: Charlotte, NC
Posts: 485
Re: JEM7V Trem Problem

Sounds like this may be your problem- http://www.ibanezrules.com/tech/setup/loose_holder.htm
Jeminizer is offline  
Reply

Tags
jem7v , problem , trem

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
JEM7V-WH - trem not even / one side higher than the other JulianH Ibanez JEM, UV, JS & Other Signature Models 5 12-11-2009 05:43 PM
Jem7v Trem Problem BlakeJem7v Ibanez JEM, UV, JS & Other Signature Models 22 05-29-2009 06:09 PM
Jem7v floating Trem Tension SlickXQ Tech: Setup, Repairs and Mods 7 07-04-2003 10:51 PM
Jem7v problem Chriscec Tech: Setup, Repairs and Mods 4 07-01-2003 05:54 AM
UV777BK trem problem - I think it is a problem (shrug) Scoff X Tech: Setup, Repairs and Mods 5 09-21-2001 12:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome