edge III problems? - Jemsite
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-27-2006, 08:10 PM Thread Starter
 
Join Date: Aug 2003
Posts: 18
edge III problems?

I recently got a new (not used) RG350DX. I have been playing it for about 2 weeks. The trem works well. When I divebomb, it returns to the same pitch every time. When I pull up, it returns to the same pitch every time. However, the pitch it returns to when I divebomb is different than the one it returns to when I pull up. This problem has been occurring since I got the guitar and hasn't gone away. By now, the springs and the strings should be properly broken in or stretched correct? So, what should I do to fix the problem? Any suggestions? Thanks for any help!
cjk3910 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-27-2006, 08:22 PM
 
Join Date: Jan 2005
Location: Singapore
Posts: 506
Re: edge III problems?

Consider buying better cut trem posts? Or filing the knife edges of the Edge III a little?

Rich has a good tech section on bad trem posts and blunt knife edges, both of what I've seen on all (about 5 guitars) Edge IIIs. Ibanezrules.com
Shredcows is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edge mysteries solved!!......? - Answers to some common ques Jason Stone Tech: Setup, Repairs and Mods 18 05-27-2008 08:35 AM
Problems with Edge... Shredcows Tech: Setup, Repairs and Mods 1 02-01-2005 09:00 AM
RG520 - Edge tuning problems RobV Tech: Setup, Repairs and Mods 5 11-30-2002 06:21 AM
RG550 and Edge problems with the Edge trem, please advice LaXu Tech: Setup, Repairs and Mods 7 08-13-2002 04:38 PM
Edge and Lo Pro Edge problems after action change - I don't Kremlin Tech: Setup, Repairs and Mods 13 07-20-2001 03:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome