Edge Zero Bridge : Set-up problems - Jemsite
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-13-2015, 03:57 PM Thread Starter
 
Join Date: Dec 2015
Location: Lucknow, India
Posts: 4
Edge Zero Bridge : Set-up problems

Hey, I have an Ibanez RG1570Z, which the Edge Zero trem. It's been around two years with this guitar, and up until recently, it played like a dream. I prefer Standard-low action, .09-.42 string guage. Whenever I had to restring, I gave it to someone from a music store nearby (the only one in town) to do so. And if ever the action seemed to get bad and way too high, he fixed it for me by tightening the action studs at the bridge. Little did I know he was doing it wrong.

After playing for a couple of days, the action went way too low with a lot of string buzz and choking. SO I went over to the store once again and he told me it would have something to do with the truss rod. So he adjusted my neck, but the action got way too high and uncomfortable for me. So he worked with the action studs again and set it up for me.

When I came home and read about it, it turns out you have to use a smaller allen wrench and first loosen the stud locks inside the bolts prior to setting up your action. Well I guess the guitar tech from the store didn't do that and now when I tried it myself I can't do it. It's like the stud locks are stuck. The guitar is playing alright but it gets out of tune really fast now. And the action could still be lowered down (which would my more comfortable to me) but now I just don't know what to do. It turns out the guy doesn't know anything about edge trems.

It seems like he's broken the set screws (the smaller studs inside the bridge studs)

Near the lower end of the bridge (near the high E,B,G strings), the allen wrench seems to get stuck every time I check for the set screws/locking studs. On the other end, it seems to be pretty loose and I can't tighten it. From what I've read on the net, it seems like when they're tightened and the stud is locked, you can't change the action. But I somehow am able to change the action in the current situation. Could this be because they aren't locked?

Is my guitar going to be alright?

If it's not, what should I do in order to get the inner stud locks back to how they should be? And also, there's still some chokes that I'm experiencing on the 17th/18th frets, whenever I bend. Help me out anyone?

Last edited by omertaxtx; 12-13-2015 at 04:17 PM.
omertaxtx is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-13-2015, 06:00 PM
Vendor
 
Rich's Avatar
 
Join Date: Dec 2000
Location: South Jersey
Posts: 25,582
Re: Edge Zero Bridge : Set-up problems

What year is it? The 1570z was a one year model here and I don't think the set screws were installed in them. They would be in the pouch with the tools.
Rich is online  
post #3 of 9 (permalink) Old 12-13-2015, 06:25 PM Thread Starter
 
Join Date: Dec 2015
Location: Lucknow, India
Posts: 4
Re: Edge Zero Bridge : Set-up problems

Got mine in the summer of '13. And they were pre-installed.
omertaxtx is offline  
post #4 of 9 (permalink) Old 12-13-2015, 06:31 PM
Vendor
 
Rich's Avatar
 
Join Date: Dec 2000
Location: South Jersey
Posts: 25,582
Re: Edge Zero Bridge : Set-up problems

In 13 they would have been.

You obviously need a better tech.
Rich is online  
post #5 of 9 (permalink) Old 12-13-2015, 06:37 PM Thread Starter
 
Join Date: Dec 2015
Location: Lucknow, India
Posts: 4
Re: Edge Zero Bridge : Set-up problems

Yes of course. It's sad out here the fact that the techs aren't familiar at all with edge trems. For a better tech, I'll have to make a visit to New Delhi. And that'd only be possible after a while. A few months I guess. Right now the guitar seems to be playing pretty good, except for the few chokes I experience when I bend on higher frets. That could be fixed by fret leveling.

What do you reckon I do?
omertaxtx is offline  
post #6 of 9 (permalink) Old 12-13-2015, 06:41 PM
Vendor
 
Rich's Avatar
 
Join Date: Dec 2000
Location: South Jersey
Posts: 25,582
Re: Edge Zero Bridge : Set-up problems

You either learn how to work on it yourself, network with other players to find somebody close that knows how to work on these guitars, they may not be a pro but probably knows why more than the store guy, or, you make the long trip.
Rich is online  
post #7 of 9 (permalink) Old 12-13-2015, 06:47 PM Thread Starter
 
Join Date: Dec 2015
Location: Lucknow, India
Posts: 4
Re: Edge Zero Bridge : Set-up problems

Right.

Do you think that the guitar might have been damaged in some way because of the set screws being damaged, if that's the case?
omertaxtx is offline  
post #8 of 9 (permalink) Old 12-13-2015, 06:49 PM
Vendor
 
Rich's Avatar
 
Join Date: Dec 2000
Location: South Jersey
Posts: 25,582
Re: Edge Zero Bridge : Set-up problems

I doubt it. You don't unlock set screws with an allen wrench, you raise the action to unlock the set screws.
Rich is online  
post #9 of 9 (permalink) Old 12-18-2015, 09:22 PM
 
Join Date: Apr 2014
Location: Toronto
Posts: 83
Re: Edge Zero Bridge : Set-up problems

I did it myself, with some confidence from Rich, got it setup. Never goes out of tune.

As Rich said, I think it's something you should familiarize with instead of relying on someone else.
Jeesan is offline  
Reply

Tags
edge zero , ibanez , prestige

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
WTT: my Gold Schaller FR bridge for your Black Lo Pro Edge or Edge bridge supergirl20_06 Classified Ads: Guitars and Gear 2 08-05-2011 05:57 AM
NGD + bridge problems :( Levi79 All Other Guitars (including Prestige) 7 10-17-2010 10:18 PM
First time with ZR Bridge & Problems, HELP! xmacvicar All Other Guitars (including Prestige) 12 12-03-2008 02:54 PM
RG550 and Edge problems with the Edge trem, please advice LaXu Tech: Setup, Repairs and Mods 7 08-13-2002 04:38 PM
Edge and Lo Pro Edge problems after action change - I don't Kremlin Tech: Setup, Repairs and Mods 13 07-20-2001 03:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome