EMG installation question.. - Jemsite
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-27-2006, 07:44 PM Thread Starter
 
Join Date: Feb 2006
Posts: 18
EMG installation question..

If any of you guys have an S series and have installed EMGs, help me out! I've got almost everything wired except for the jack. I can't get it in the hole where the original jack was; it's not long enough and there's not enough room to get the washer and nut in. Can you guys help me out? Thanks.
MaidenNH is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-27-2006, 07:48 PM
 
Join Date: Jan 2005
Location: Toronto
Posts: 1,923
Re: EMG installation question..

You should be able to use the original Ibanez output Jack. The switchcraft barrel jack that Ibanez uses is usually a stereo one. just unsolder the wires off the EMG jack and put them on the original Ibanez jack. The ground and live go where the ground and live wires were before and you wire the battery clip to the unused lug.
buddroyce is offline  
post #3 of 9 (permalink) Old 12-27-2006, 07:53 PM Thread Starter
 
Join Date: Feb 2006
Posts: 18
Re: EMG installation question..

I thought about doing that but EMG covered one of the connections with this little rubber sleeve that I can't get off. Maybe I'll give it another go.
MaidenNH is offline  
post #4 of 9 (permalink) Old 12-27-2006, 07:54 PM
 
Join Date: Dec 2005
Location: Arlington, TX
Posts: 3,069
Re: EMG installation question..

Then just cut it off
C.Thep is offline  
post #5 of 9 (permalink) Old 12-27-2006, 07:56 PM Thread Starter
 
Join Date: Feb 2006
Posts: 18
Re: EMG installation question..

Good point.
MaidenNH is offline  
post #6 of 9 (permalink) Old 12-27-2006, 07:59 PM
 
Join Date: Jan 2005
Location: Toronto
Posts: 1,923
Re: EMG installation question..

I guess I forgot to mention the cutting off part..
buddroyce is offline  
post #7 of 9 (permalink) Old 12-27-2006, 11:55 PM Thread Starter
 
Join Date: Feb 2006
Posts: 18
Re: EMG installation question..

Ok so I got it installed and working, but now all I'm getting is a clean sound. No distortion at all.
MaidenNH is offline  
post #8 of 9 (permalink) Old 12-27-2006, 11:59 PM
 
Join Date: Jan 2005
Location: Toronto
Posts: 1,923
Re: EMG installation question..

No distortion at all usually means that you're not getting any or enough power to the pickups. I know this may sound strange, but have you tried a different battery? If you have, double check to make sure that your pickups are in deed getting power. I had the same problem once when I installed a set of EMG 707/81-7's in a RG1527 for a client once. Fixed the problem with a new 9v battery. (the dumb thing was the first battery was also fresh out of the package... I guess it depends on how long it's been sitting on the store shelf.)
buddroyce is offline  
post #9 of 9 (permalink) Old 12-28-2006, 12:09 AM Thread Starter
 
Join Date: Feb 2006
Posts: 18
Re: EMG installation question..

I tried 3 different batteries; no luck.
MaidenNH is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with EMG 85 pickup installation LonePhantom Pickups & wiring 12 08-23-2005 06:03 PM
Yet another EMG question :) Jslegacy Pickups & wiring 2 03-31-2003 01:29 PM
EMG pickup installation trouble nocebo Pickups & wiring 4 03-26-2003 07:59 AM
EMG Afterburner question Break Zero Pickups & wiring 4 03-12-2003 01:00 PM
Hello again & question on EMG 707s. - Where can I get a good revsharp777 Gear, Equipment, Recording & Off Topic 3 01-14-2001 01:10 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome