Ibanez S61AL issue - Jemsite
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

 1Likes
  • 1 Post By Heep
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-21-2020, 06:55 AM Thread Starter
 
Join Date: Mar 2020
Posts: 1
Ibanez S61AL issue

Hello a couple of months ago i have bought the Ibanez S61AL i am really happy with the guitar its absolutely amazing in regards of features and look for the price but there is an issue that really bothers me.

I need a new 9v battery almost every week. I dont know why the battery drains so fast is it because of the fisherman pickups?

Will it help if keep the guitar unplugged from the amplifier?

Thanks for the tips
lakiscy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-21-2020, 08:59 AM
 
Join Date: Jan 2014
Location: France
Posts: 128
Re: Ibanez S61AL issue

Unplug the jack on the guitar side when not playing it.
peromucho7 likes this.

Last edited by Heep; 03-21-2020 at 09:40 AM.
Heep is offline  
Reply

Tags
battery , s61al

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome