need help with a problem with my tremolo! - Jemsite
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 09-04-2004, 11:32 AM Thread Starter
 
Join Date: Sep 2004
Posts: 4
need help with a problem with my tremolo!

i have a rg2620 saphire blue ibanez with edge pro saddle.

The problem is that the tremolo arm is loose so that its hard to use the tremolo and i'm not sure if something is going to break (the saddle or the arm) if i continue to use it... it's just like if the hole in the saddle for the arm was too wide... the problem occured some time ago and i changed the teflon washers and that helped but now it's loose again and i don't think the teflon washers are ment to be replaced every couple of weeks...

what should i do? new teflon pieces again so that i can play a couple of weeks again with the tremolo working properly?
Omso is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 09-04-2004, 07:02 PM
Kontalonis is offline  
post #3 of 10 (permalink) Old 09-04-2004, 11:14 PM
 
Join Date: Aug 2004
Posts: 204
is it loose as in the arm swings around or does it feel detatched from the bridge?
bobojem is offline  
post #4 of 10 (permalink) Old 09-11-2004, 08:46 AM Thread Starter
 
Join Date: Sep 2004
Posts: 4
It feels detached from the bridge... it's supposed to swing around right?
is the nailpolish thing going to help if the arm feels detached? i don' t care how much it swings... i just want it to feel like it's part of the bridge and not "wobble" in it's hole...

i'm just having doubts about putting nail polish on any of the parts of my guitar... i mean... is it really what everyone does? no better way to do the job? can the nail polish for example damage anything?
Omso is offline  
post #5 of 10 (permalink) Old 09-11-2004, 12:59 PM
 
Join Date: Apr 2004
Posts: 636
are the white rings on the tip visible?
Wis Redz of Silvanost is offline  
post #6 of 10 (permalink) Old 09-11-2004, 02:18 PM
 
Join Date: Apr 2001
Location: Minneapolis MN
Posts: 1,056
The trem arm holder might be loose. Yu'll have to take the trem off and look underneath. There is a nut that holds it secure.
CrossingStar is offline  
post #7 of 10 (permalink) Old 09-12-2004, 08:11 AM Thread Starter
 
Join Date: Sep 2004
Posts: 4
no the rings aren't visible... the arm is how it should be... maybe i'll have to take the tremolo off then...
Omso is offline  
post #8 of 10 (permalink) Old 09-12-2004, 08:30 AM Thread Starter
 
Join Date: Sep 2004
Posts: 4
i read the tech setup page on jemsite and i found out exactly what i have to do... thanks
Omso is offline  
post #9 of 10 (permalink) Old 09-12-2004, 12:26 PM
 
Join Date: Mar 2004
Location: Huddersfield/Leeds, West Yorkshire, UK
Posts: 1,373
Let us know how it goes, if you get into trouble or don't feel comfortable doing it then you can always try looking at the how to pull a trem section on ibanezrules.com in the tech area, i used that guide and found it simple enough, kinda hard to break anything really lol
Andelusion is offline  
post #10 of 10 (permalink) Old 09-12-2004, 01:07 PM
 
Join Date: Aug 2004
Posts: 204
I think you're refering to the loose arm socket. I've had the same problem before, no biggie. I just took the trem off and screwed the socket tight with the screw on the back of the bridge piece. And yea, let us know how it goes
bobojem is offline  
Reply

Tags
arm holder , trem arm , trem arm holder , tremolo arm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tremolo Arm Problem!! \Dom/ All Other Guitars (including Prestige) 1 05-18-2012 11:21 AM
ZR tremolo problem Tomm89 All Other Guitars (including Prestige) 17 04-13-2010 02:53 AM
Problem with 03/04 ZR Tremolo lyconxero Tech: Setup, Repairs and Mods 3 01-31-2006 10:09 PM
Lo Pro Tremolo problem Pikaciao Tech: Setup, Repairs and Mods 3 11-13-2005 01:39 PM
tremolo problem.... :( rx Ibanez JEM, UV, JS & Other Signature Models 14 04-01-2005 06:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome