pickup switching problem ? - Jemsite
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-17-2008, 11:02 AM Thread Starter
 
Join Date: Jul 2006
Location: London, Uk
Posts: 133
pickup switching problem ?

I have a a JC 1702 witha 5 way pickup selector, and the other day it was switching pickups and noticing no difference at all ? The sound is usually quite significant but now i can't hear any change when flicking between any of the 5 positions. Is this a common problem ? or could it be a wiring issue?
ShellyOFG is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-17-2008, 11:19 AM
 
Join Date: Mar 2006
Location: Moncton NB, Canada
Posts: 206
Re: pickup switching problem ?

Quote:
Originally Posted by ShellyOFG View Post
I have a a JC 1702 witha 5 way pickup selector, and the other day it was switching pickups and noticing no difference at all ? The sound is usually quite significant but now i can't hear any change when flicking between any of the 5 positions. Is this a common problem ? or could it be a wiring issue?

Did you do any changes to the wiring, swap pickups or open the backplate to touch something? I'm sure its not wired so the bridge pickup is in all 5 position.

Put the pickup selector in the bridge position and tap your pick on the pole pieces of the bridge pickup, then with the pickup selector still in the bridge tap your pick on the pole piece of the neck pickup. Then put the pickup selector in the neck position. and do the same thing, tap your pick on the pole pieces of the bridge pickup and then the neck pickup. When you hit the pole pieces of where the pickup selector is actually in it should be louder. This will ensure you all five positions are not using just the bridge pickup.

Sounds to me like your ear is just having a bad day and it all sounds the same.
70Seven is offline  
post #3 of 4 (permalink) Old 05-17-2008, 11:57 AM Thread Starter
 
Join Date: Jul 2006
Location: London, Uk
Posts: 133
Re: pickup switching problem ?

Quote:
Originally Posted by 70Seven View Post
Did you do any changes to the wiring, swap pickups or open the backplate to touch something? I'm sure its not wired so the bridge pickup is in all 5 position.

Put the pickup selector in the bridge position and tap your pick on the pole pieces of the bridge pickup, then with the pickup selector still in the bridge tap your pick on the pole piece of the neck pickup. Then put the pickup selector in the neck position. and do the same thing, tap your pick on the pole pieces of the bridge pickup and then the neck pickup. When you hit the pole pieces of where the pickup selector is actually in it should be louder. This will ensure you all five positions are not using just the bridge pickup.

Sounds to me like your ear is just having a bad day and it all sounds the same.
The neck pickup makes a sound when tapping it, however the bridge pickup doesnt :S
also i havent touched any wiring at all. I did knock it a little, but really not hard at all.. at least to make any difference, or so I would assume

EDIT: Okay i've been listening really carefully and it seems like the bridge and the neck pickup seem identical, and the middle position is sharper [more like a bridge pickup] Could it be possible the bridge pickup has come loose? or gone a bit dead ? I wouldn't see that making it go a warm muddier sound though :/ this is wierd [I probably sound like a complete idiot / noob, but i know what i hear :P] Its just difficult to explain

Last edited by ShellyOFG; 05-17-2008 at 12:15 PM.
ShellyOFG is offline  
post #4 of 4 (permalink) Old 05-22-2008, 03:18 PM
 
Join Date: Mar 2008
Location: Canada
Posts: 122
Re: pickup switching problem ?

I've been having a similar problem with my rg2570, seems the neck and the bridge pick ups work properly by themselves, but the three positions in the middle are very quiet, when I move the selector switch slightly to the left the volume kicks in again, ( it's like the connection is being made ), this guitar is only a month old. It's a rg2570 so it has the DiMarzio/IBZ pick ups. I haven't made any modifications at all. On a clean amp setting should all 5 pick up positions have the same volume? This has taken the fun outta playing this guitar. any ideas?
Stringz is offline  
Reply

Tags
bridge pickup , bridge position , neck pickup , neck position

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
The ultimate dimarzio pickup thread j.arledge Pickups & wiring 23 01-15-2009 03:20 PM
Pickup Height Problem Mehrunes Tech: Setup, Repairs and Mods 6 07-14-2007 12:27 PM
Problem with 2003 7Vwh JEM, Possibly New Edge Pro Trem Fault leonard deroma Ibanez JEM, UV, JS & Other Signature Models 89 06-18-2007 10:57 AM
JEM pickup problem geetarmonkey Pickups & wiring 4 09-29-2004 05:06 PM
Push/Pull Pot switch - pickup switching keith Tech: Setup, Repairs and Mods 2 03-16-2001 07:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome