Edge 3 problem again - Jemsite
Tech: Setup, Repairs and Mods Guitar workbench discussion such as setup, repairs, mods, installing new parts and more.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-23-2011, 08:07 AM Thread Starter
 
Join Date: Apr 2011
Location: Windsor ontario Canada
Posts: 11
Exclamation Edge 3 problem again

k guys i have a problem with my trem. I was just playing normally after i adjusted the string height a bit and use tremolo slightly, then there was a loud noise. I noticed that one of my saddles went all the way forward. Now all my strings are out of tune. what is the problem? do i just normally intonate it?
tophermathews is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-23-2011, 08:59 AM
 
Join Date: Dec 2009
Posts: 554
Reviews: 6
Re: Edge 3 problem again

You'll have to pull the string in question, but either the intonation screw was loose, and it pulled towards the neck, throwing the tuning off, or the screw snapped. Screws are usually available at fastener supply houses.

As well, it's possible something larger is wrong with the bridge. The only way to find out is to pull the string off and have a look.

Last edited by Philboski; 06-23-2011 at 09:14 AM.
Philboski is offline  
post #3 of 5 (permalink) Old 06-23-2011, 09:09 AM Thread Starter
 
Join Date: Apr 2011
Location: Windsor ontario Canada
Posts: 11
Re: Edge 3 problem again

k then it sounds pretty complicated ill give it in to a guitar tech thanks for the help.
tophermathews is offline  
post #4 of 5 (permalink) Old 06-23-2011, 09:18 AM
 
Join Date: Dec 2009
Posts: 554
Reviews: 6
Re: Edge 3 problem again

Removing a string and looking at the screw is NOT complicated.
Philboski is offline  
post #5 of 5 (permalink) Old 06-23-2011, 11:08 AM
 
Join Date: Jan 2011
Location: baton rouge
Posts: 3,922
Reviews: 11
Re: Edge 3 problem again

you should really learn how to set up a floyd rose yourself. It will save you headaches and money in the long run.

As others stated, your saddle slid forward most likely because the set screw vibrated loose. When that happened the string tension on it loosened. Im guessing it was one of the thicker strings that did it. When that happens the balance on the floyd rose goes out of whack, and it pulls back. Im guessing the other strings are high out of pitch?
linuxpenguin is offline  
Reply

Tags
edge 3 bridge , ibanez rg350ex

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edge Pro problem Andrimner Tech: Setup, Repairs and Mods 12 10-13-2009 03:38 PM
edge pro problem. help? DanEwins Tech: Setup, Repairs and Mods 1 03-22-2009 12:40 PM
edge 3 problem prydogga Tech: Setup, Repairs and Mods 3 01-07-2009 08:31 PM
Lo pro edge & Double Edge in tune problem Raffel Tech: Setup, Repairs and Mods 21 05-14-2004 08:59 AM
Wierd Lo-Pro Edge 7 problem... big problem! Jupiter Tech: Setup, Repairs and Mods 5 06-11-2003 01:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome