Edge lo pro out of tune issue - Jemsite
Tech: Setup, Repairs and Mods Guitar workbench discussion such as setup, repairs, mods, installing new parts and more.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-02-2013, 02:30 PM Thread Starter
 
Join Date: Mar 2012
Location: Katy, TX
Posts: 43
Edge lo pro out of tune issue

Hey guys,


I have a friend who has a guitar (7620) with the lo pro. When you pull up on the bar it causes the guitar to go out of tune every time. To fix, you have to push down (dive) on the bar and let go and it brings it right back into tune every time. Guitar has new strings.


Any ideas on how to fix this before I take it to a local shop ($$)?


Thanks ahead
BuffDaddySmurf is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-02-2013, 08:09 PM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,232
Reviews: 120
Re: Edge lo pro out of tune issue

Lube the knife edges with chap stick. Check out the tech section of ibanezrules.com
LonePhantom is offline  
post #3 of 4 (permalink) Old 06-02-2013, 09:21 PM
 
Demogorgos's Avatar
 
Join Date: Mar 2006
Location: Madrid, Spain
Posts: 1,195
Exclamation Re: Edge lo pro out of tune issue

Sounds like the same issue I had with my UV (at the luthier now to fix the issue)

My detuning was due to wiggling trem studs + the inner metal piece in the body where the pivoting screws of the trem are inserted has a wiggle too...

Start from there before looking for other causes.

As mentioned before, Rich's ibanezrules.com has useful info as how to proceed.

Regards,

JP
Demogorgos is offline  
post #4 of 4 (permalink) Old 06-28-2013, 10:37 AM
 
Join Date: Apr 2013
Location: hereford, uk
Posts: 212
Re: Edge lo pro out of tune issue

Quote:
Originally Posted by LonePhantom View Post
Lube the knife edges with chap stick. Check out the tech section of ibanezrules.com

Do this, i had same problem, spent 5 minutes doing this worked like a dream
newblues is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edge Zero tremolo arm issue satchtabber Tech: Setup, Repairs and Mods 18 07-08-2015 08:05 AM
Extreme Tuning issue with Edge-Pro Cemges Tech: Setup, Repairs and Mods 1 08-30-2012 05:34 AM
Edge trem issue Severinsteelsmith Tech: Setup, Repairs and Mods 2 01-20-2010 01:05 AM
Double Edge Tremolo Issue RG1820X Pickups & wiring 0 11-30-2008 05:37 PM
Lo pro edge & Double Edge in tune problem Raffel Tech: Setup, Repairs and Mods 21 05-14-2004 08:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome