Edge zero II trem arm - Jemsite
Tech: Setup, Repairs and Mods Guitar workbench discussion such as setup, repairs, mods, installing new parts and more.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-31-2011, 08:08 PM Thread Starter
 
Join Date: Aug 2011
Location: United Kingdom
Posts: 23
Edge zero II trem arm

I have a relatively minor issue with the trem arm for the edge zero II on my ibanez premium, even though its only minor its driving me crazy.

The problem is when i screw the trem arm into the trem its a little loose (wobbles slightly), its the same issue people complain about with the edge 3 but on the edge 3 theres a little Allen wrench screw under the trem that can fix this but i cant find the same thing on the edge zero II.

I know its only a small problem but its really starting to bug me and it prevents me from being able to flutter the bridge and its just plain annoying in general.

If anyone has a solution or a fix for this i would be grateful to hear it.

Thanks.
dangerous_rob is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-31-2011, 08:17 PM
 
RGTFanatic's Avatar
 
Join Date: Jun 2003
Location: New Lenox, IL-USA
Posts: 10,116
Reviews: 2
Re: Edge zero II trem arm

Maybe shoot AlaskaBat a PM about this issue....I know he's done some in depth stuff with his EZ2
RGTFanatic is offline  
post #3 of 6 (permalink) Old 08-31-2011, 08:20 PM Thread Starter
 
Join Date: Aug 2011
Location: United Kingdom
Posts: 23
Re: Edge zero II trem arm

Thanks man, ill see if he can help me
dangerous_rob is offline  
post #4 of 6 (permalink) Old 09-01-2011, 05:24 PM Thread Starter
 
Join Date: Aug 2011
Location: United Kingdom
Posts: 23
Re: Edge zero II trem arm

Other members please feel free to offer solutions (if any)...
dangerous_rob is offline  
post #5 of 6 (permalink) Old 11-29-2012, 10:52 AM
 
Join Date: Nov 2012
Location: Argentina
Posts: 5
Re: Edge zero II trem arm

Quote:
Originally Posted by dangerous_rob View Post
Other members please feel free to offer solutions (if any)...
Hey Rob, have you found a solution??
I have a 350dxz with ez2. I bought it one week ago and it makes a noise when i pull the arm down and then inmediatly pull it up.
chomps1404 is offline  
post #6 of 6 (permalink) Old 04-29-2013, 09:23 PM
 
Join Date: Apr 2013
Location: Bolivia
Posts: 1
Re: Edge zero II trem arm

same with me...i have also an rg350dxz and that clicky sound is @#&%! annoying!!!! does anyone have a solution??? PLEASE!!!!
fabior is offline  
Reply

Tags
edge zero ii trem arm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edge pro trem or Gotoh trem wanted jsdisciple Classified Ads: Ibanez JEM/UV Guitars 0 06-08-2011 08:59 AM
How to remove ZR trem, destroy it, then install Edge trem? bdk Tech: Setup, Repairs and Mods 16 07-25-2010 01:33 PM
Ugraded an Edge 2 trem to a Lo Pro or Edge Pro? Stabilty issues? Look here. longi Tech: Setup, Repairs and Mods 6 04-17-2010 04:42 PM
WTB: Trem Arm holder for Ibanez Edge trem Dale Classified Ads: Guitars and Gear 1 11-10-2007 10:17 AM
FT: Black Cosmo Lo-Pro Edge Trem for your Chrome Lo-Pro or Original Edge Trem parker_fly Classified Ads: Guitars and Gear 4 02-19-2005 03:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome