Terrible Feedback - Jemsite
Tech: Setup, Repairs and Mods Guitar workbench discussion such as setup, repairs, mods, installing new parts and more.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-11-2013, 09:50 PM Thread Starter
 
Join Date: Nov 2011
Location: United States
Posts: 5
Terrible Feedback

Ok I've been having a premium RG920 for about a year now and it's been working fine. I just turned on my amp and heard some bad feedback. Tested everything...it's not the cables or amp. Can somebody please help?!
chrisrab5150 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-11-2013, 09:56 PM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,235
Reviews: 120
Re: Terrible Feedback

What exactly have you tried? A guitar just doesn't start feedbacking unless the pickups have been damaged, and they're not exactly easy to damage when they are in a guitar.
LonePhantom is offline  
post #3 of 7 (permalink) Old 04-11-2013, 09:59 PM Thread Starter
 
Join Date: Nov 2011
Location: United States
Posts: 5
Re: Terrible Feedback

Well all I did was plug the guitar straight into the amp and there was still feedback. I plugged another cable in then tried another amp. I also tried another guitar. It was working fine last night. The guitar hasnt been touched since then.
chrisrab5150 is offline  
post #4 of 7 (permalink) Old 04-11-2013, 10:03 PM Thread Starter
 
Join Date: Nov 2011
Location: United States
Posts: 5
Re: Terrible Feedback

I should add the guitar did fall of its holder last week but it's worked fine since then and there wasn't much damage.
chrisrab5150 is offline  
post #5 of 7 (permalink) Old 04-11-2013, 10:05 PM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,235
Reviews: 120
Re: Terrible Feedback

OK, so it fell. Then potentially some wiring connections have been damaged. Did it fall face first? You might have stuffed up the pickup selector or something.
LonePhantom is offline  
post #6 of 7 (permalink) Old 04-11-2013, 10:08 PM Thread Starter
 
Join Date: Nov 2011
Location: United States
Posts: 5
Re: Terrible Feedback

It fell off its stand back first but I caught it before it fell all the way down. It played fine since then so I didn't think too much of it.
chrisrab5150 is offline  
post #7 of 7 (permalink) Old 04-11-2013, 10:12 PM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,235
Reviews: 120
Re: Terrible Feedback

Quote:
Originally Posted by chrisrab5150 View Post
It fell off its stand back first but I caught it before it fell all the way down. It played fine since then so I didn't think too much of it.
Well something's been loosened, and I guess now what ever was damaged is completely loose. Open up the back cavity and take a look. Might be a loose wire. Could be a damaged switch, which won't be immediately apparent.
LonePhantom is offline  
Reply

Tags
feedback , ibanez , premium , rg920

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
A terrible, terrible story of a lost Jem... TheFreak777 Ibanez JEM, UV, JS & Other Signature Models 21 11-01-2011 07:47 PM
again.. terrible situation here.. spkenn5 Vendors, Auction & Reseller Talk 17 12-11-2006 05:08 PM
Help my terrible vocals!!!!! FinnJ Gear, Equipment, Recording & Off Topic 16 11-14-2003 09:15 AM
gt-2..sounds terrible. woodros Gear, Equipment, Recording & Off Topic 5 03-21-2003 09:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome