65 Bassman 50 , the tubes light up, but no sound ?? - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-30-2011, 12:04 AM Thread Starter
 
Join Date: Apr 2011
Location: tucson
Posts: 9
65 Bassman 50 , the tubes light up, but no sound ??

65 Bassman 50 , the tubes light up, but no sound ??
Any suggestions what this could be ?
Thank you
eVILj is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-30-2011, 03:11 AM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,233
Reviews: 120
Re: 65 Bassman 50 , the tubes light up, but no sound ??

Connection between speaker and amp broken?
LonePhantom is offline  
post #3 of 3 (permalink) Old 05-30-2011, 03:26 AM
 
Join Date: Jan 2011
Location: baton rouge
Posts: 3,922
Reviews: 11
Re: 65 Bassman 50 , the tubes light up, but no sound ??

FUSES! Just dont blow all your tubes when you put the cab back in haha
linuxpenguin is offline  
Reply

Tags
bassman 65 50 amp head

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
fender bassman amp losgatosrg350dx Gear, Equipment, Recording & Off Topic 0 03-29-2008 07:18 PM
Light.Colour.Sound. toma Players & Bands, Music & Sounds, Tours & Jams, Lessons & Theory! 0 07-23-2006 08:52 AM
Can bad tubes cause "buzzing or sizzling" sound? Rotti Gear, Equipment, Recording & Off Topic 1 01-19-2005 09:38 PM
ELusive Light and Sound JEM icarus Ibanez JEM, UV, JS & Other Signature Models 3 03-27-2003 05:24 AM
Tubes - Who plays 5881s? - they sound better than the Mesa 6 luther Tech: Setup, Repairs and Mods 4 03-10-2001 12:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome