Amp issues - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-26-2003, 01:17 AM Thread Starter
 
Join Date: Jun 2002
Location: Vancouver, WA
Posts: 47
Amp issues

alright this whole post is just gonna lack useful information I'll get more tomorrow but my friend has a problem with his amp where it randomly switches from channel A to channel B and vice versa, just whenever it feels like it apparently, any vague ideas of what the problem is?
Sypher is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-26-2003, 04:20 AM
 
Join Date: Dec 2000
Location: Atlanta GA
Posts: 24
Sounds like he needs to replace the cable from the amp to the channel foot switch. I had the exact same thing happen to me at a show a couple of weeks ago and the cable turned out to be the culprit. To check, have him unplug the foot switch and play for a little while to see if the amp still misbehaves. My guess is that it won't.

If the cable isn't replacable (ie built into the footswitch) then it's probably time for a new foot switch.

-Lance
lance is offline  
post #3 of 4 (permalink) Old 02-26-2003, 08:30 PM Thread Starter
 
Join Date: Jun 2002
Location: Vancouver, WA
Posts: 47
yea thats what I figured this amp sounds fairly old its a celestion, like the front of the amp says celestion its a 2x12 with you guessed it celestions, but I've never seen a celestion brand amp before, celestion speakers in everything but an amp, first time for everything I guess I'll take a look at the footswitch.
Sypher is offline  
post #4 of 4 (permalink) Old 02-27-2003, 09:34 PM Thread Starter
 
Join Date: Jun 2002
Location: Vancouver, WA
Posts: 47
went to the kids house, yea no footswitch, it just switches channels on its own, now I'm real confused.
Sypher is offline  
Reply

Tags
foot switch

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with my RG so far... jm1681 Tech: Setup, Repairs and Mods 13 01-20-2007 02:35 PM
amp issues. littlewing777 Tech: Setup, Repairs and Mods 4 12-28-2006 02:24 AM
Jem YM-50 Issues... keithmoore Tech: Setup, Repairs and Mods 1 10-24-2006 02:31 PM
PM issues littlegreenman Off-topic / Miscellaneous 5 08-27-2005 02:04 PM
Nut issues woodros Tech: Setup, Repairs and Mods 5 03-12-2004 01:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome