Does anyones reverb on the legacy sound weak?? - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-25-2010, 08:51 AM Thread Starter
 
Join Date: Jan 2008
Location: kansas land of oz
Posts: 425
Does anyones reverb on the legacy sound weak??

I have a real nice Legacy head but the reverb is really weak for an accutronics system..
Has anyone replaced their tank???
just42dave is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-26-2010, 05:29 PM Thread Starter
 
Join Date: Jan 2008
Location: kansas land of oz
Posts: 425
Re: Does anyones reverb on the legacy sound weak??

?????
just42dave is offline  
post #3 of 7 (permalink) Old 01-26-2010, 05:52 PM
 
JayRobIBZ's Avatar
 
Join Date: Jan 2002
Location: Palmer, Alaska
Posts: 534
Reviews: 3
Re: Does anyones reverb on the legacy sound weak??

is it tube driven? I can't recall.
JayRobIBZ is offline  
post #4 of 7 (permalink) Old 01-26-2010, 06:07 PM
Contributor
 
Cornbread's Avatar
 
Join Date: Feb 2005
Location: plano, tx
Posts: 75
Re: Does anyones reverb on the legacy sound weak??

i have the combo and it has more than enough. i have mine set on 3 and it is just fine. reverb is tube driven so you can try switching the tubes around to see if it gets better. if it does then the tube was bad. good excuse to upgrade to new ones
Cornbread is offline  
post #5 of 7 (permalink) Old 01-26-2010, 06:28 PM
 
JayRobIBZ's Avatar
 
Join Date: Jan 2002
Location: Palmer, Alaska
Posts: 534
Reviews: 3
Re: Does anyones reverb on the legacy sound weak??

I should have never opened this thread. I wan't my Legacy back
JayRobIBZ is offline  
post #6 of 7 (permalink) Old 01-28-2010, 12:01 AM
 
Join Date: Nov 2009
Location: Vancouver, BC
Posts: 49
Re: Does anyones reverb on the legacy sound weak??

The reverb on the legacy is meh. get a holy grail and splooge everywhere
Pewtershmit is offline  
post #7 of 7 (permalink) Old 01-28-2010, 11:54 PM Thread Starter
 
Join Date: Jan 2008
Location: kansas land of oz
Posts: 425
Re: Does anyones reverb on the legacy sound weak??

I just think its very weak Ill try another tube but I know the tube I have is phenominal
Im wondering If I need a new tank..Its there but man I shouldnt have to turn it on 10
just42dave is offline  
Reply

Tags
legacy vai

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Parker P38 - anyones take? rikkbeatty Gear, Equipment, Recording & Off Topic 12 07-23-2015 11:28 AM
Help! pickups sound weak. wiring problem? xPrestigeRGAx Pickups & wiring 4 09-18-2008 09:33 PM
Help! Pickups sound weak? Is it just my setup? jbandy10 Tech: Setup, Repairs and Mods 15 04-27-2008 08:13 PM
Coil tap - weak clean sound? aenis Ibanez JEM, UV, JS & Other Signature Models 5 06-27-2007 09:19 PM
Noisy reverb on Carvin Legacy ThomasBJ Gear, Equipment, Recording & Off Topic 8 11-03-2006 04:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome