Edge pro with tremol-no - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-18-2012, 01:31 AM Thread Starter
 
Join Date: Oct 2012
Location: Maryland
Posts: 29
Edge pro with tremol-no

Hey folks. Got a jem a couple weeks ago and I installed the tremol-no a week ago. Guitar wasn't staying in tune so I thought the strings need to stretch more. So I've been playing and stretching for a while. Today I noticed that the bridge never returns back to the same position when you use the whammy. So it will never be in tune. It's almost like there's no "zero point" for the edge pro. It always comes back either higher or lower than it was before depending on how you use the whammy bar and what direction you take. I'm really confused about this I was told the tremol-no would provide tuning stability among its others features. I'm a full floating guy so I have no need for the other features. But nonetheless they don't even work. The thumb screws are all the way in and the bridge still moves it just doesn't seem strong at all. I bought the item new and followed step by step the YouTube video. I'm running 10s on 3 springs and the bridge is parrallel and perfect to the body... Really don't know what's going on. Any help is appreciated can provide pictures as well.

Regards,
Cristian
cpelaez is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-18-2012, 02:52 AM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,186
Reviews: 120
Re: Edge pro with tremol-no

Tremol-no aids tuning stability when locked or in dive only mode. Zero point when using full floating will only ever be as good as you get your Edge Pro to balance, and if you have the Tremol-no set correctly. The locking of the spring claw to the attachment springs can sometimes throw it off from memory, but again if your Edge Pro is not correctly balanced, knife edges lubed, etc you'll have issues.
LonePhantom is offline  
post #3 of 3 (permalink) Old 10-22-2012, 11:13 AM
 
Join Date: Oct 2001
Location: Minnesota
Posts: 99
Re: Edge pro with tremol-no

I have an Apex 1 with a Tremol-no in it, and I just got another Apex 1 on Saturday that does not. In all honesty, I think I like it better without, and have it tuned A-flat, and I'm honestly surprised with the tuning stability. I may take the T-no off the other one. I think it is a cool idea, and I'm pretty good at setting up trems, but I think the locking mechanism makes it tougher to tune in northern climates, where we see SIGNIFICANT neck shifting throughout the year.
chrisolson is offline  
Reply

Tags
tremol no jem

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edge Pro + ESP Arming Adjuster + Tremol-No. Possible? MetalZone Tech: Setup, Repairs and Mods 16 04-12-2011 03:43 PM
FS: Edge Lo-Pro, Dimarzio Pickups, Tremol-no Robbo Classified Ads: Guitars and Gear 4 04-20-2009 06:53 PM
Buying guitar today!!! Tremol-No on an Edge Zero? elbarno Tech: Setup, Repairs and Mods 8 02-26-2009 04:44 PM
Tremol-No on Edge Pro? Gudster All Other Guitars (including Prestige) 17 11-03-2007 08:18 PM
wtb: Tremol-no newbieguitarmaker Classified Ads: Guitars and Gear 4 10-01-2007 06:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome