FX Loop problems - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-02-2011, 05:44 PM Thread Starter
 
Join Date: Nov 2006
Location: UK,LONDON
Posts: 1,060
Reviews: 17
FX Loop problems

So my brother bought a DD3 today and we plugged it into the FX loop but the amp starts making a hum/buzz......is that normal?

Maybe we're plugging it in wrong? Do we put a NS-2 in front of it or something? We're kinda new to the whole FX loop thing so help would be appreciated.

Amp is a Peavey 6505. We are currently running a TS9 and NS-2 in front of the amp.
Speedabob is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-02-2011, 05:47 PM
 
Join Date: May 2007
Location: Serbia
Posts: 576
Reviews: 2
Re: FX Loop problems

Do you use batteries or power adapter to power the DD3? If it's the adapter, try sticking a battery in and see if that helps. Daisy chained supplies can create ground loops that cause terrible hum.
Cheers
bancika is offline  
post #3 of 8 (permalink) Old 06-02-2011, 05:49 PM Thread Starter
 
Join Date: Nov 2006
Location: UK,LONDON
Posts: 1,060
Reviews: 17
Re: FX Loop problems

We have a battery in all our pedals. we tried different leads too, no difference.
Speedabob is offline  
post #4 of 8 (permalink) Old 06-03-2011, 03:48 AM
 
Join Date: Apr 2010
Location: Australia
Posts: 242
Reviews: 2
Re: FX Loop problems

If your still getting hum and running EVERY pedal on batteries, then i would think maybe a faulty pedal somewhere.

Try plugging the guitar directly into the amp, with the DD3 in the loop. If there is still hum, try different leads. Then try a different guitar, then try it without the DD3. If taking the DD3 out removes ur problem, get a replacement.

Toodles Julz!
julzius is offline  
post #5 of 8 (permalink) Old 06-10-2011, 11:29 AM Thread Starter
 
Join Date: Nov 2006
Location: UK,LONDON
Posts: 1,060
Reviews: 17
Re: FX Loop problems

i think the DD3 is the problem, Any idea what would need fixing on it? Because without it there is no hum.
Speedabob is offline  
post #6 of 8 (permalink) Old 06-10-2011, 11:36 AM
 
Join Date: Oct 2009
Location: Georgia, USA
Posts: 2,878
Reviews: 4
Re: FX Loop problems

Delays and reverbs have a tendency to amplify small buzzes and make them loud, try some different settings, see if it changes, then try bypassing it. Are you using a battery or power supply? could be ground hum from a wall outlet to the PSU. just considerations.
fwd0120 is offline  
post #7 of 8 (permalink) Old 06-19-2011, 03:07 AM
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,155
Re: FX Loop problems

I wonder if the cable described here will help:
http://www.rjmmusic.com/blog/2011/06...-loop-problem/
Petie is offline  
post #8 of 8 (permalink) Old 06-19-2011, 03:59 AM
 
Join Date: May 2007
Location: Serbia
Posts: 576
Reviews: 2
Re: FX Loop problems

there shouldn't be a ground loop if he's using batteries, but there's no harm in trying
bancika is offline  
Reply

Tags
6505 , boss , dd3 , delay , hum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Use FX loop or not? ESPdude Gear, Equipment, Recording & Off Topic 7 04-27-2008 01:48 AM
fx loop help astro929 Gear, Equipment, Recording & Off Topic 1 01-14-2007 03:47 PM
Rg 3120 Problems. ANNOYING PROBLEMS!!!! Given to Fly All Other Guitars (including Prestige) 20 05-24-2003 01:24 PM
Problems using an effects loop-please help mginty Gear, Equipment, Recording & Off Topic 3 12-06-2001 03:46 PM
Legacy effect loop - possible ground loop hum? bill h Gear, Equipment, Recording & Off Topic 4 08-12-2001 03:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome