GSP21 Pro error 888 ??? - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-01-2010, 06:44 PM Thread Starter
 
Join Date: Sep 2010
Location: Woodinville, WA
Posts: 2
GSP21 Pro error 888 ???

I just got a used GSP21 Pro, which worked fine before shipping. It was packed well, and cushioned, but upon turning it on, all I get is "888" in the display, and no sound output. Doing a reset does nothing. Anybody encountered this, or have a fix for it?
ansilatoms is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-01-2010, 10:40 PM
Banned
 
Join Date: Dec 2008
Location: Houston, TX
Posts: 9,291
Reviews: 98
Re: GSP21 Pro error 888 ???

There seems to be a lack of web info on this. You might want to drop the Digitech folks a message.



AlaskaBat is offline  
post #3 of 3 (permalink) Old 09-01-2010, 11:00 PM Thread Starter
 
Join Date: Sep 2010
Location: Woodinville, WA
Posts: 2
Re: GSP21 Pro error 888 ???

Digitech has discontinued repair, and as such, any real support on the early GSP's. I'll rattle the cage, again, but don't hold out much hope.
ansilatoms is offline  
Reply

Tags
888 , digitech , error , gsp21 pro

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
send error report gggrrr rob777vdy Off-topic / Miscellaneous 3 12-08-2008 05:22 PM
The sequencing error Myst and rain Polls 0 12-05-2006 10:20 AM
An error in the Jemsite's specs for the 77BRMR...(I hope!) Van Ibanez JEM, UV, JS & Other Signature Models 6 09-30-2006 09:24 AM
Jemsite home page error message mitchmarshall Off-topic / Miscellaneous 4 01-05-2006 09:08 PM
jemfest.com homepage error message - fyi - not sure if you'r jemsite Players & Bands, Music & Sounds, Tours & Jams, Lessons & Theory! 4 05-19-2001 09:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome