Marshall 5213, doesn't work. - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-04-2003, 10:23 AM Thread Starter
 
Join Date: Nov 2002
Location: Helsinki, Finland
Posts: 77
Marshall 5213, doesn't work.

I have a Marshall Mos-Fet(?) model 5213 solid state 2x12 amp.
It had a problem that when i played little longer, it muted.
I found out that when it warms up, it doesn't work anymore.
So i took it to a my friends friend who fixes amps. Then i
found out, that the other speaker hadn't worked at all!
How couldn't i hear it? How much does a new speaker cost?
And what kind of speaker it has to be? The non-working was a
Celestion sidewinder 65(?) Should buy another Celestion? (I heard
that they are very expensive! (200$)) Or should i buy a cheap speaker
like this http://www.netzmarkt.de/thomann/thoi...el-107153.html Although it says Eminence, i heard that they are not real Eminence.
Well the Amp came just yesterday to me, and
now i hope it works well! I think he chanced some circuits
or something. I think it works now, but i don't know, 'cos i haven't
played it very much. It also had a problem that the Eq in the dist channel
doesn't work when the footswitch Boost is on. Is this normal on the
Marshalls or is there something broken?
pace520 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
This doesn't work . . . I could use a clue. tonepot Pickups & wiring 4 07-27-2010 03:38 PM
Marshall Modifications That Really Work.... jemaholic Gear, Equipment, Recording & Off Topic 16 05-23-2007 10:11 AM
Why doesn't my signature work? zEr0 Forum Announcements and Member Help 1 11-09-2004 05:28 PM
my ada doesn't work the second eye Gear, Equipment, Recording & Off Topic 5 10-13-2003 07:41 PM
Whammy bar is too loose and the nailpolish doesn't work Dave Goodland Tech: Setup, Repairs and Mods 9 10-28-2002 01:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome