Marshall JMP-1 level control problem - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-08-2009, 06:31 PM Thread Starter
 
Join Date: Jul 2008
Location: Manchester
Posts: 128
Marshall JMP-1 level control problem

help, ive cleaned the output level knob underneath with contact cleaner, its still scratchy and occasional get volume dips, like when you press on it its ok, but its doing my head in, what can i do?

im really experienced at guitar stuff, but im not sure what else to do here
rockguitar4ever is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-08-2009, 08:19 PM
 
Join Date: Jul 2005
Location: racine, WI
Posts: 1,499
Reviews: 7
Re: Marshall JMP-1 level control problem

Take it to an amp tech and have the pot replaced, not much else you can do.
brothersnowgone is offline  
post #3 of 3 (permalink) Old 09-08-2009, 10:56 PM
DJR
 
Join Date: Jul 2002
Location: Kent, UK
Posts: 289
Re: Marshall JMP-1 level control problem

there's a tiny square open notch on the bulb-bass of the pot, you need to aim the contact cleaner into there and spray a tiny amount while rotating the knob, which will mean opening up the casing to get to it. Make sure there's no liquid on the circuits before turning back on. If it's still under warranty (unlikely since they haven't been produced for a while), Marshall would do this, or replace the pot for you if you drop it off at a local Marshall dealer, and get them to deal with the returns number/collection etc.

Scratchy pots are irritating enough, but if the volume dipping leads to the level knob not working at all (still getting signal, but no control via the knob), then a factory reset will do the trick most of the time.

Last edited by DJR; 09-08-2009 at 11:03 PM.
DJR is offline  
Reply

Tags
jmp-1 , marshall

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Marshall AVT150 Ali___ Gear, Equipment, Recording & Off Topic 4 04-14-2004 01:23 PM
Marshall DSL 100 Effects Loop Problem JohnnyRasgueado Gear, Equipment, Recording & Off Topic 0 07-14-2003 11:07 PM
marshall 1960tv rattling problem FinnJ Gear, Equipment, Recording & Off Topic 2 05-04-2003 02:27 PM
Marshall Problem 7 Dying Trees Gear, Equipment, Recording & Off Topic 4 12-05-2002 05:13 AM
marshall valvestate amp problem vwall Tech: Setup, Repairs and Mods 0 07-27-2002 09:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome