RME Fireface 400 driver nightmares or suggest me an interface - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-19-2012, 03:00 AM Thread Starter
 
Join Date: Dec 2003
Location: Lithuania
Posts: 20
RME Fireface 400 driver nightmares or suggest me an interface

Hi guys,

It's been forever since I last posted, but here I go with a little problem. My father gave me his old RME Fireface 400 audio interface and it is fantastic... when it works. I got at least 5 BSODs every day ever since I started using it and I said - to hell with it. I then went and connected my ancient Terratec Phase 24, which is very limited - only 2in/2out and the headphone monitoring out is noisy. Anybody here use a Fireface on 64-bit Windows 7 systems? Maybe there's a trick to make it stable? Some combination of firmware and driver versions? I really like the connectivity and sound quality, but the latest drivers are just a mess. RME is quick to point fingers at shoddy FireWire controllers, but I have a Texas Instruments one so the controller is not a problem. Besides, my other interface is rock stable on it.
voyager is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-19-2012, 05:32 PM
 
jb4674's Avatar
 
Join Date: Apr 2002
Location: Fairfax, VA - USA
Posts: 4,612
Reviews: 18
Re: RME Fireface 400 driver nightmares or suggest me an interface

What are your machine's specs? Have you updated the Fireface's firmware to the latest version?

This is taken from the RME forum (http://www.rme-audio.de/forum/viewtopic.php?id=7348) :

Installation of RME Audio Interfaces under Windows 7

The procedure and instructions found in the manual and here are all fully correct and stay valid, except for the start of the installation. In Windows 7 Microsoft removed the automatic start of the Driver Software Update dialog - thank you Microsoft!

Therefore this dialog has to be started manually after the failed driver installation.

- Hit the Win key, type 'Device Manager', start the Device Manager by selecting it from the list and hit Return.

- The device is shown with a yellow warning symbol. Usually it is already found in the correct category, Sound, Video and Game Controller (Plug & Play detects a multimedia device). The Fireface UC is even shown with its correct name.

- Right click on the device and select 'Update Driver Software' from the context menu.

- The dialog 'Update Driver Software' appears. Now follow the instructions given in the manual.


And here's the link for the latest drivers:

http://www.rme-audio.de/en_downloads...river_fireface


Make sure to uninstall all drivers/RME software in your machine and then reboot prior to reinstalling to make sure everything is erased.

Jimmy
jb4674 is offline  
post #3 of 5 (permalink) Old 10-20-2012, 03:28 AM Thread Starter
 
Join Date: Dec 2003
Location: Lithuania
Posts: 20
Re: RME Fireface 400 driver nightmares or suggest me an interface

Did everything, even reflashed the firmware although it was already the latest version, rebooted after every step and so far so good. I'm gonna test it for a few days and if it still gives me BSODs it's going to the classifieds.
voyager is offline  
post #4 of 5 (permalink) Old 10-30-2012, 04:05 AM Thread Starter
 
Join Date: Dec 2003
Location: Lithuania
Posts: 20
Re: RME Fireface 400 driver nightmares or suggest me an interface

Looks like I solved my problems for good. The trick was to uninstall the drivers, disconnect the interface, reboot, replace the TI firewire driver with a one named "legacy", reboot and then install the interface as usual. No more, BSODs, no more dropouts, no more crackles under heavy load.
voyager is offline  
post #5 of 5 (permalink) Old 10-30-2012, 12:02 PM
 
jb4674's Avatar
 
Join Date: Apr 2002
Location: Fairfax, VA - USA
Posts: 4,612
Reviews: 18
Re: RME Fireface 400 driver nightmares or suggest me an interface

Glad you were able to sort out the problems that way. I had to do something similar with my Firestudio a few years ago when I built a new Win7 box.

Jimmy
jb4674 is offline  
Reply

Tags
bsod , rme fireface

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New oversampling ASIO driver Scali Gear, Equipment, Recording & Off Topic 23 05-22-2016 08:55 AM
WTB : RME FIREFACE 800 OR 400 lelahel Classified Ads: Guitars and Gear 2 10-05-2011 12:49 PM
nightmares having guitar built!!!! alxman Off-topic / Miscellaneous 15 08-12-2009 03:57 PM
Erotic Nightmares - Steve Vai cover Ad_Astra Players & Bands, Music & Sounds, Tours & Jams, Lessons & Theory! 8 08-22-2008 11:52 PM
MY NEW TAYLOR MADE DRIVER! Out Of This Swirled Off-topic / Miscellaneous 13 08-29-2007 08:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome