Tube Question (Gain) - Page 2 - Jemsite
Gear, Equipment, Recording & Off Topic Gear, Equipment, and Recording discussed here. Amps, pedals, whatever.

Reply
 
LinkBack Thread Tools Display Modes
post #16 of 25 (permalink) Old 08-04-2008, 09:46 AM
 
Join Date: Jun 2003
Location: Philadelphia, PA, USA
Posts: 540
Re: Tube Question (Gain)

The amount to which an amp overdrives has a lot to do with its circuitry, which you can't change. I kind of find it hard to believe that a Valve King would not have enough "umph," but I'm not really part of the metal genre. If you're worried about tone coloration from a pedal, how about using a "clean boost" sort of pedal like an MXR Micro Amp? Basically it acts just like an extension of your guitar's volume control.
ken_r152 is offline  
Sponsored Links
Advertisement
 
post #17 of 25 (permalink) Old 08-04-2008, 09:47 AM Thread Starter
 
Join Date: Dec 2006
Location: UK
Posts: 240
Reviews: 20
Re: Tube Question (Gain)

Also- do you think its possible the texture knob on the back could be faulty or would a tube cause that effect?
Thanks
Regards
Jonny
Guitarist-Jonny is offline  
post #18 of 25 (permalink) Old 08-04-2008, 09:54 AM Thread Starter
 
Join Date: Dec 2006
Location: UK
Posts: 240
Reviews: 20
Re: Tube Question (Gain)

It used to give me loads of gain but doesn't now. I'm not a heavy player myself but I can't get more than a crunch on the thin side from the amp now :S! It's can't get it to give any meat like even for just heavier rock tones!
Guitarist-Jonny is offline  
post #19 of 25 (permalink) Old 08-04-2008, 10:58 AM Thread Starter
 
Join Date: Dec 2006
Location: UK
Posts: 240
Reviews: 20
Re: Tube Question (Gain)

I just had the amp on again- when its on, the tube 2nd in on the left does not glow blue at all whilst the far left glows a very dim blue and the two on the right hand side glow happily a strong blue (all have the orange 'filament' i will call it lol.) Is that power tube failure?
Thanks
Regards
Jonny
Guitarist-Jonny is offline  
post #20 of 25 (permalink) Old 08-04-2008, 02:09 PM Thread Starter
 
Join Date: Dec 2006
Location: UK
Posts: 240
Reviews: 20
Re: Tube Question (Gain)

Actually I think there's two that don't glow blue- the two on the left hand side when looking front the front of the amp through to the back- as I said they do all have the glowing orange center. Could this be power tube failure dudes?
Thanks
Regards
Jonny
Guitarist-Jonny is offline  
post #21 of 25 (permalink) Old 08-05-2008, 07:35 AM
 
Join Date: Dec 2007
Location: Germany
Posts: 116
Re: Tube Question (Gain)

Yep man, looks like your tubes are going south, just get some new ones, it won't break the bank and it'll make the VK sound much better!! 18 months sounds about right for replacing tubes anyway so it was bound to happen.

I've had my VK112 for 10 months now but all is still fine...
varador is offline  
post #22 of 25 (permalink) Old 08-05-2008, 08:06 AM Thread Starter
 
Join Date: Dec 2006
Location: UK
Posts: 240
Reviews: 20
Re: Tube Question (Gain)

Good stuff, thanks dude ! Would that explain the lack of gain though and the reason why the texture knob seems to just quieten the amp rather than meat it up?
Thanks
Regards
Jonny
Guitarist-Jonny is offline  
post #23 of 25 (permalink) Old 08-05-2008, 09:47 AM
 
For_The_Love_Of_Jems's Avatar
 
Join Date: Nov 2007
Location: NJ, USA
Posts: 693
Reviews: 1
Re: Tube Question (Gain)

My suggestion is not to guess, take it to an amplifier specialist immediately! There could be a larger reason why your tubes are burning out. Get a pro to take a look at it.

Good Luck!
For_The_Love_Of_Jems is offline  
post #24 of 25 (permalink) Old 08-05-2008, 10:25 AM Thread Starter
 
Join Date: Dec 2006
Location: UK
Posts: 240
Reviews: 20
Re: Tube Question (Gain)

I will- I'll get it sorted once and sort of for all lol :P! Thanks to everyone for your time and efforts helping me out I really appreciate it- Thanks !
Best Regards
Jonny
Guitarist-Jonny is offline  
post #25 of 25 (permalink) Old 08-25-2008, 11:00 PM
 
Join Date: Jan 2008
Location: kansas land of oz
Posts: 425
Re: Tube Question (Gain)

I got some tubes for ya 3 12ax7 and what does the valveking have el34s or 6l6
just42dave is offline  
Reply

Tags
amp distortion , palm mute , peavey valveking , preamp tube , spring reverb , valve king

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in











Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best tube high gain amp at bedroom volumes rlintz Gear, Equipment, Recording & Off Topic 14 01-07-2008 06:55 PM
Tube Question Thrash Gear, Equipment, Recording & Off Topic 2 11-21-2005 08:14 PM
Power tube gain question AdamBilz Gear, Equipment, Recording & Off Topic 18 01-11-2005 07:35 AM
Tube Question... Elysian Tech: Setup, Repairs and Mods 3 12-01-2004 03:35 PM
tube question.... chris state Gear, Equipment, Recording & Off Topic 2 04-14-2003 06:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome