Help:problems installing Dimarzio Dominion set - Jemsite
Pickups & wiring Discussion about pickup types, replacements, recomendations, switching, wiring diagrams and sustainer systems for ANY guitar, JEMs included.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 03-08-2012, 10:38 PM Thread Starter
 
Join Date: Mar 2011
Location: charlotte, nc
Posts: 18
Help:problems installing Dimarzio Dominion set

Hi guys, Need some help. I installed a set of dominions in my 1570 while leaving the stock middle pickup. I also replaced the volume and tone pots. I installed the bridge pickup with the d in dimarzio on the bottom away from the knobs. The neck pickup the d is toward the knobs. I read they needed to go in like this so I ignored the f on the pickup. After installing, I only have sound in positions 1 and 5. I twisted bare and green together and black and white together for both and wired into the same spots it was in before. Is my middle pickup out of phase? I have no sound at all for positions 2, 3, and 4. Any help would be greatly appreciated. Thanks, Todd
Toddz rgr465 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-09-2012, 01:38 AM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,233
Reviews: 120
Re: Help:problems installing Dimarzio Dominion set

Did you connect the red (hot) to position one and 3 on the switch (where the old humbucker hot wires were, and the combined white and black to the split wires on the switch?
LonePhantom is offline  
post #3 of 8 (permalink) Old 03-09-2012, 01:47 AM
 
Join Date: Dec 2010
Location: Chicago, IL
Posts: 475
Re: Help:problems installing Dimarzio Dominion set

Can you draw a diagram or post a picture? It'll be easier for us to help. If everything is soldered in the right spot, it could just be a cold joint. Make sure none of your connections wiggle.

If it was out of phase, you'd still hear something. It creates a weaker signal, it doesn't get canceled completely.
xXLinkageXx is offline  
post #4 of 8 (permalink) Old 03-09-2012, 07:31 AM Thread Starter
 
Join Date: Mar 2011
Location: charlotte, nc
Posts: 18
Re: Help:problems installing Dimarzio Dominion set

Yes the reds are on pos. 1 and 3. I will try and diagram what i did later today when I get back into the guitar. My girlfriend did it and she installs electronic components for work so all my solder joints should be good-she really double and triple checked them. Does it matter which way the pickups are in the guitar? i looked online and it said to make the D go a certain way on both-I did this. However, the markings on the back of the pickup(the f) don't face the neck on neck pickup(it does on the bridge pickup). Could this be causing anything and are they oriented right the way they are placed there now? I'll post back later today with where my connections are going, etc. Thanks for trying to help. Todd
Toddz rgr465 is offline  
post #5 of 8 (permalink) Old 03-09-2012, 07:41 AM Thread Starter
 
Join Date: Mar 2011
Location: charlotte, nc
Posts: 18
Re: Help:problems installing Dimarzio Dominion set

Lone Phantom what do you mean about connecting the black/white to the splits? They are soldered to the last contact point on the switch(opposite end of the red wires) and to the 3rd point.(from that end). I used a dimarzio 1570 wiring diagram and put everything where it said. I copied the jumpers and wired the middle(factory) pickup with the ibanez wiring diagram. (At least they work by themselves-that's how I will use it 99% of the time but I want it to work correctly).The pickups sound good though. very full single note sound. don't seem terribly hot with distortion, just thick. Kind of unexpected for a pickup used by one of the heaviest bands out there. Thanks everyone for your assistance. Will be back later with a wire by wire account of what I did. Todd
Toddz rgr465 is offline  
post #6 of 8 (permalink) Old 03-09-2012, 10:01 AM
 
Join Date: Dec 2010
Location: Chicago, IL
Posts: 475
Re: Help:problems installing Dimarzio Dominion set

Quote:
Originally Posted by Toddz rgr465 View Post
Lone Phantom what do you mean about connecting the black/white to the splits? They are soldered to the last contact point on the switch(opposite end of the red wires) and to the 3rd point.(from that end).
What you did is what he means, it's right. Just to be clear, is this what you did? Ignore if the switch is facing the opposite direction, it makes no difference.


EDIT:
On second thought, it sounds like the middle pickup's wires are touching somewhere. This would allow the signal to go straight to ground in the 2, 3, and 4 position. Make sure you check where they actually come out of the pickup.

Last edited by xXLinkageXx; 03-09-2012 at 10:28 AM.
xXLinkageXx is offline  
post #7 of 8 (permalink) Old 03-09-2012, 02:43 PM
 
Join Date: Jan 2005
Location: Canberra, Australia
Posts: 9,233
Reviews: 120
Re: Help:problems installing Dimarzio Dominion set

Yeah, something must be slightly touching somewhere I'm guessing. Go over it all again just to make sure.
LonePhantom is offline  
post #8 of 8 (permalink) Old 03-10-2012, 03:37 PM Thread Starter
 
Join Date: Mar 2011
Location: charlotte, nc
Posts: 18
Re: Help:problems installing Dimarzio Dominion set

got a diagram from dimarzio showing the factory single coil and the two dimarzio humbuckers. the wiring is exactly the same. the dimarzio tech suggested the switch wiring was wrong. well we redid all the switch contact points and i still have no signal in pos2,3,and4. i also think there is more hum than there should be. we also redid the volume ground.absolutely no change. i will check the wires to make sure they aren't touching anywhere. what type switch goes in there-i might try a new one of those as a last resort. i really don't want to have to pay someone to do this.
Toddz rgr465 is offline  
Reply

Tags
no sound w middle pup

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
DiMarzio Dominion bridge - WOW! LonePhantom Pickups & wiring 3 03-02-2012 05:44 AM
Help Installing Dimarzio SS into RG1570 cjbscotland Pickups & wiring 1 06-18-2009 05:15 AM
Installing Dimarzio PickUps XcitR Pickups & wiring 3 05-26-2008 10:21 AM
Need help installing Dimarzio in RG570!! King Nothing Pickups & wiring 9 04-20-2006 07:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome