Jemsite - Reply to Topic
Tech: Setup, Repairs and Mods Guitar workbench discussion such as setup, repairs, mods, installing new parts and more.

Thread: Problem with Lo-Pro Edge Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-23-2017 02:53 AM
mixlikes
Re: Problem with Lo-Pro Edge

If it is not adjusted by you then you can go to where you have bought this guitar.
10-27-2017 02:46 AM
vyansal
Re: Problem with Lo-Pro Edge

Lock the nut screws.
10-26-2017 07:51 PM
Rich
Re: Problem with Lo-Pro Edge

1. Lube first - Chapstick

2. Lockdown procedure - IBANEZ RULES!! tech - setup

only file as a last resort.
10-26-2017 04:16 PM
Leviathus
Re: Problem with Lo-Pro Edge

Sounds like the knife edges of your trem may need sharpening.

IBANEZ RULES!! tech - setup

Rich'll show ya how^
10-26-2017 03:37 PM
Fam
Problem with Lo-Pro Edge

Hi,

Every time I tune my JEM7V-WH (2001 model) and do a dive bomb, everything goes flat. And if I pull the bridge up after that, everything goes sharp (back to where it originally was). I have not faced this issue before. It started to happen after I had adjusted string height, so I'm guessing it could have something to do with that. What should I do?

EDIT:

I realize I wasn't being very clear. Here's an example of what happens:
-I tune the guitar normally
-Do a dive bomb
-After the bridge returns to parallel level with the body, everything has gone slightly flat
-And if I pull the bridge up, everything goes back to where it originally was (or very close to it, at least)

I purchased the guitar earlier this year, and I've had 0 issues with it thus far. Though one thing I guess I should mention; I don't think the locking screws inside the studs were tightened by the previous owner. When I adjusted the action earlier today, I was following the instructions Rich has on his site. The instructions say to loosen the locking screw. I'm pretty sure it was already loose (on both sides). I did tighten them when I was done adjusting the action, and I did not use any serious force.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome