Jemsite - Reply to Topic
Tech: Setup, Repairs and Mods Guitar workbench discussion such as setup, repairs, mods, installing new parts and more.

Thread: Edge zero 2 noob mistakes. Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-10-2019 06:00 PM
Duncan Smith
Edge zero 2 noob mistakes.

I'm still fairly new to this forum but I have had some great insights since joining regarding setup of my new RG350DXZ. I say new but it was a shop damaged item, big chunk of paint missing on the back after it was dropped (picture below) which I am in the process of patching up using a catalyst resin filler. I got it for 210 so I feel like I got a bargain. Its a great guitar but there are the expected shortcomings that come with a low-ish budget guitar, mostly just lack of attention to detail in finishing, cavities not finished well which needed a bit of a rub down, fretwork etc. The pickups seem pretty good, quantum, they seem pretty ballsy to my ears. The biggest issue I am having is the bridge setup, I've got the basics down set level, intonation sorted and action seemed ok up until today. I was using the whammy bar and suddenly the whole trem dropped down a couple of millimetres into the cavity. I took a close look at what was going on and the knife edge on the bottom E side had slipped down the post. After taking the stings off i also realized that the washers on the top E saddle (pics) lock and the fine tuner were both underneath the saddle itself. I had noticed earlier that to set the top E action I had to set the bridge so low that the trem was actually sitting at the same level as the body which did seem odd to me, now I realize that was because the saddle was about a millimetre too high. Also because the washer was placed incorrectly the locking screw allen wrench socket has stripped a bit which must be due to the extra tension needed to tighten it because of the washer being in the wrong place. I've ordered some more locking screws but they will take a week or do to arrive so in the meantime I have just removed the whole bridge assembly so I can clean the bad finishing job up in the cavity and get a nice finish on my repair job on the back.Although I wouldn't have expected the dealer to set the bridge up for me given that it was only 210. I am a bit disappointed though that the washers were out of place on the saddle. Also going back to the issue of the knife edge slipping down the post that was due to the fact that it was not actually sitting in the groove on the post at all on the bottom E side as the post shows evidence of where it was sitting (pic). These are all issues I suppose a more experienced trem user may have noticed but I am a bit new to the whole FR type system. Thankfully there doesn't seem to be any permanent damage to anything and at least after removing it all I have a better idea of how it all works.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome