Jemsite - Reply to Topic
Pickups & wiring Discussion about pickup types, replacements, recomendations, switching, wiring diagrams and sustainer systems for ANY guitar, JEMs included.

Thread: Schaller-S type switch vs YM-50 wiring, help please Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-10-2020 01:22 PM
Ivan75
Schaller-S type switch vs YM-50 wiring, help please

The RG in question is HSH, Evos and a True Velvet in the middle.
My YM50 5-way switch is gone, I wanted a CRL but I couldn't find one ina short notice.
So I wired a Schaller Megaswitch type ''S''

The wiring was standard RG with an additional neck (or bridge) pup splitting using the Push/pull switch when the lever is on neck or bridge. Everything else was standard and it worked fine.
Now, on wiring it all according to Schaller website instructions, I ended up with both humbuckers in split mode whatever you do with the push/pull.
What I'm doing now is cross-referencing the switches to find the wrong connections, for now, I think I should just forget the Schaller instructions, (no additional split coils mentioned there), and just wire it the way the YM50 was wired?
So basically the question is are the switches (Schaller and YM50) mapped the same way? If so, I can disregard the website wiring template.
Any thoughts?
I posted an image of the diagram that actually worked.
I actually just did it according to the diagram, it does not work at all, I hope I just turned the switch backwards while soldering so reversing it would solve the problem. If not, I really don't know what to do.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome