Jemsite - Reply to Topic
All Other Guitars (including Prestige) Discussion about other Ibanez Guitars not covered in the above topics. Includes J-Custom, USA-Custom, Prestige subforum.

Thread: Steinberger string problem Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Jemsite forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address

IMPORTANT: You will be required to activate your account so please ensure that your email address is correct.

If you do not receive your activation check your spam folder before using the CONTACT US form (at the bottom right of each page).



Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-06-2011 04:57 PM
dragsternj
Re: Steinberger string problem

The thread is 6 years old man
01-06-2011 04:47 PM
ChrisRussell
Re: Steinberger string problem

Well. The Trans-Trem is amazing. The R-Trem is the crappiest of them all. The Spirit models are not good. Ebay has Trans-Trems and S-Trems for sale a lot of times. But that is like $900 right there. Maybe the brand of string.
01-03-2011 12:31 AM
SonicProvocateur
Re: Steinberger string problem

Wow...I didn't even notice the thread date lol.

Necro threads ARISE!
01-01-2011 09:40 PM
AxeHappy
Re: Steinberger string problem

Quote:
Originally Posted by retrofunk View Post
Interesting post, I joined this site to put my two bits in I have found several of these adapters that work very well (being a long time Steinberger lover). Although I would recommend and personally prefer using the double ball end string because of its ability to perform better, I still use headless string adapters when needed. the added convenience of being able to use any set of string anytime is a major bonus.
I found several stores selling them online:
Travel Guitar Store.com
GuitarSend.com

You joined this site to put your 2 cents in on a 5(6 now!) year old thread? Something smells fishy here.
12-31-2010 02:17 PM
SonicProvocateur
Re: Steinberger string problem

I used GHS, LaBellas and Steinberger strings and never had that issue on my old Spirit GU7R. 'Twas a wicked guitar...wish i hadn't sold it. Borrom line is you HAVE to use double ball ended strings and the tremolo has to be free of burrs just like any other tremolo.
12-31-2010 11:05 AM
retrofunk
Re: Steinberger string problem

Interesting post, I joined this site to put my two bits in I have found several of these adapters that work very well (being a long time Steinberger lover). Although I would recommend and personally prefer using the double ball end string because of its ability to perform better, I still use headless string adapters when needed. the added convenience of being able to use any set of string anytime is a major bonus.
I found several stores selling them online:
Travel Guitar Store.com
GuitarSend.com
04-16-2005 01:17 PM
JESTER700
Re: Steinberger string problem

Or GHS. I used those before I got the string adapter and they worked well.
04-16-2005 11:25 AM
revsharp777
Re: Steinberger string problem

Which strings is he using? If he's using those cheapass Music Yo Strings, he'll pop the high string every time. I know from experience. Tell him to get a set of double ball LaBellas at juststrings.com
04-16-2005 10:51 AM
dangomles
Re: Steinberger string problem

Check this out:

http://www.steinberger.com/techinfo.aspx

Perhaps you could find some helpful info
04-16-2005 10:47 AM
necromancer69
Steinberger string problem

I have just sold a steinberger spirit, and have recieved a complaint from the purchaser. The problem is that when he bends the top E string, it breaks at the bridge end just before the ball. He has tried to replace the string 3 times and the same thing has happend on all 3 occasions. I have never encountered this problem, so i was wondering if anyone out there could help.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome