Ibanez JEM Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have an RG770dx reissue that has the original edge tremelo. I was curious if anyone here with the same bridge has to pull up slightly on the bar after a rigorous dive bomb to reset the bridge back to zero. I experienced the same thing on an ibanez I once owned with the edge 3 tremelo.
 

·
Registered
Joined
·
47 Posts
Make sure your strings are properly stretched and clean the trem posts/knife edges. Make sure to use some vaseline or something on the knife edges and trem posts afterwards.

This usually does the job very well.
 

·
Registered
Joined
·
493 Posts
hi, as a above lube the posts and stretch your strings, those trems are great functioning units....


Regards,
Nelson
 

·
Registered
Joined
·
16 Posts
I had the same problem on my RG350 with the edge III. I just readjusted the springs that hold the trem back. Fixed the problem and in stays in tune alot better. If you need to know how , let me know.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
I had the same problem on my RG350 with the edge III. I just readjusted the springs that hold the trem back. Fixed the problem and in stays in tune alot better. If you need to know how , let me know.
I don't consider it a problem, but rather a quirk of ibanez trems...the original edge being one of the best trems ibanez has made and the edge 3 which usually goes on the lower end models; I originally thought there was something wrong with my ibanez js20s that had the edge 3 but now I realize there was nothing wrong with it at all and just a quirk of some ibanez tremelos. I never used a ZR bridge so I can't speak for them...
 
1 - 9 of 9 Posts
Top