Ibanez JEM Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hi. Im trying to assemble and install an Ibanez Original Edge trem and Im confused, hoping for some help. Hoping you knowledgeable ones can steer me away from my ignorance.

I have what I believe to be an Original Edge trem. The block is black and says "Ibanez Edge Japan"

My spring lock bar and screws are giving me trouble.

In particular it seems the screws are too big for the holes in the trem block theyre supposed to go into.

What am I missing? Do I have the wrong screws? Wrong bar?

Is my bridge/block correct for an Original Edge?

I'm almost positive I have the proper bar and screws for an Original Edge. I ordered them from Ibanezrules.

I cant figure out if I have the wrong screws, the wrong block, or what's going on lol

I googled pictures and it seems like some blocks have larger bored holes in the two spots where the bar is screwed into the block but others seem as if all the holes are the same size equally, for the spring ends.

Another general question I have is: are spring claw screws and springs essentially universal across brand lines (Fender, Ibanez, Floyd Rose)? Ive read that spring claw screws are basically #8 1/4 wood screws.

Thanks in advance for any help!

Also, I tried to upload pictures I took, which would likely be helpful, but I guess they were too large. I will attempt to reduce their size and upload them when I have a bit more time.

Thanks

Cheers
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 · (Edited)
Hi, everyone. Im still stumped in my Edge rebuild attempt, so Im back again seeking some help and guidance. Hopefully posting a follow up on my original post is the best way to go about this at this point but Im not sure.

Referring to the diagram and terminology above, one of the problems Im having is that the block lock screws are not the right size/fit to screw into the holes on the block. I ordered the block lock and screws from Ibanezrulez


Also, Im going to try to post a picture of all the parts I have.

Can someone tell me what I may still be missing? Or what problems I may have with the parts I do have?

Thanks so much in advance, this is getting a bit frustrating and I just do not possess the requisite knowledge to figure this out on my own.
 

Attachments

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 · (Edited)
I know I am missing a trem claw wood screw, as I mentioned in my original post.

Also, Ive resized my pictures and after the two I posted above I cannot get anymore to upload despite being resized to the same ones that were uploaded successfully.Is there a 2 image limit per thread? Im confused. Any suggestions on this? Im trying to upload the image of all of my parts, but I cant upload the image.

Apparently Ive maxed my allotment for uploading because Ive uploaded 104.3 KBs?


Thank you.
 

·
Vendor
Joined
·
26,380 Posts
The block holes definitely look small, but nothing has changed on the blocks, unless that's an extremely early block I don't know about. Black blocks were last used in 87' but first in 85' but I don't see any reason they would have changed.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #6 ·
Thanks for replying Rich. No wonder I was so confused, I'm pretty stumped if you yourself have never seen a block with holes like these and won't work with the block lock screws you sell. But they definitely don't fit, so I need a work-around. I'm wondering, do you have any idea if maybe I could find screws that do fit, somewhere somehow? I have no idea what size the screws you carry are but obviously I need slightly smaller ones.

Thanks Again.
 

·
Vendor
Joined
·
26,380 Posts
Hardware store to find out what the thread is, then alot of Google.

It's actually not required. Springs have always been bent back and tip barbed to avoid pop out, although with some crazy full range pullups one will pop every now and then. No S models ever came with a bar.
 
1 - 7 of 7 Posts
Top