Ibanez JEM Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
246 Posts
Discussion Starter · #1 ·
I tried my new Marshall RF-1 Reflector reverb pedal today and it gives a sweet reverb. Unfortunately I also experienced what I've read several places on the internet; that it suddenly stops working. After a good hour all I got out of it was ... nada. Nothing at all.

Light was on, battery new (and yes, I also tried with adapter), patch cables new and fully functional.

Of course, as I plugged it in at home now to start troubleshooting, the box was working again. Nasty scratching sound on one of the preset reverbs, but other than that it worked. Does anyone know how to fix this?
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #4 ·
Yeah, seems to be a common problem for some reason. Today it works perfectly fine, so I'll give it another week or so before eventually returning it. The Holy Grail would have been in my effect chain a long time ago if EHX hadn't been so damned difficult with their power supply solutions.
 

·
Registered
Joined
·
1,206 Posts
Yeah, my "big box" EHX has that darned 1/8th" adapter which sometimes loads up and becomes slightly noisy after 45 minutes or so of constant use. The holy grail plus is a great variation of it, but the flerb option is more flangy-sounding (much more in the mix). I prefer my big box. They are very cheap used on evilbay.

Maybe try the Line 6 verbzilla, I tried one and totally almost bought it spot on. Very very versatile!
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #6 ·
Seems like I've worked around the problem now. I first thought that with an adapter connected it wouldn't matter if the battery had little power left but that wasn't the case. By only using the adapter and removing the battery all together has stopped the noise and instability.
 
1 - 6 of 6 Posts
Top