Ibanez JEM Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Hi, I am in trouble.
I have an Ibanez RG Prestige 2550EGK with DiMarzio/IBZ pickups.

I just bought an AirNorton and a DSonic to replace the 2 original H but I want to keep the IBZ middle S since I don't use it too much.

So I soldered the 2 new H wires exactly where the originals were soldered.
But now I have an incredible hum!!

I am pretty sure all my solderings are good, I am testing the grounds with a multi-meters and everything seems good but the hum is really bad.

Any ideas? Maybe I have to inverse the 2 wires of the single to match the two new Humbeckers?

Another info: when I touch any components of the electronic section, pickups, pots, bridge etc...I hear a pop and the hum behaviour seems to change.

Please help!!
 

·
Registered
Joined
·
1,205 Posts
are you sure they're wired properly? Not quite sure if DiMarzio/IBZ's use the same color codes as straight Dimarzio's but they're usually wired like this:
green + bare = volume pot (ground)
black + white = switch (coil tap for pos 2 + 4)
red = switch (hot)

don't need to reverse wires for the single coil.

Reg
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
are you sure they're wired properly? Not quite sure if DiMarzio/IBZ's use the same color codes as straight Dimarzio's but they're usually wired like this:
green + red = volume pot (ground)
black + white = switch (coil tap for pos 2 + 4)
red = switch (hot)

don't need to reverse wires for the single coil.

Reg
You mean green + bare = pot? This is what I did...
Black + White togheter on the same place where the IBZ were...
Red = to the same place where the IBZ were...

But the hum is unbarable...
I don't know what to do :-(
 

·
Registered
Joined
·
1,205 Posts
mmm... double check if all the grounds are connected; from the pots, jack and to the claw. Sounds like a loose ground wire somewhere in the circuit.

Reg
 
1 - 7 of 7 Posts
Top