Ibanez JEM Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
First post here!
I replaced the edge III on my rgr465m with a brand new ofr, it stays in tune, but doesn't return to pitch. I'm thinking the edge iii bridge posts/studs might be the issue because the trem knife edges and trem angle are 100% fine.
I was talking to a mate earlier who suggested getting better quality studs that are the same size but I wouldn't know where to look as I've never attempted it before!
Any help would be appreciated.
 

·
Registered
Joined
·
667 Posts
Edge iii posts are definitely your problem. They are trash. If you put the original edge posts in then you should be golden. You could lube them with some 3 in one oil or d'addario friction remover. Sometimes that's all it needs. But if they are worn... You won't have much luck with lubing the posts where the knife edges meet.
 

·
Vendor
Joined
·
26,504 Posts
You can't just change the studs without changing the anchors which are much larger. Lack of lube is probably your biggest problem. Chapstick would be my choice.
 

·
Vendor
Joined
·
26,504 Posts
That comes via Gary Brawer via another famous tech I've long forgotten. IMO Big Bends Nut Sauce, [which I believe Brawer is part owner] is thinned Chapstick. I just use the regular stuff 8O
 

·
Registered
Joined
·
667 Posts
Definitely gonna use that. I have a guitar with Schaller floyd posts and a gotoh floyd. It is a little more high maintenance than my edge trem guitars when it comes to returning to zero consistently. Probably because the posts are a bit more of a V shape.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top