Ibanez JEM Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone, have any pia owners faced this problem? I have had 3 different pias, all with the same grounding issue, crackling noise when touching or operating the tone and volume pots that disappears completely if you touch the bridge while doing it. After the swaps I had my dealer send it back to ibanez (headstock in the uk) and it's just come back, supposedly fixed. Its improved but crackle is still present.

Getting a bit sick of having to keep sending it back now to be honest...
 

·
Vendor
Joined
·
26,766 Posts
Are you talking mild dirty pot type crackling? Only when turning the pots, not when they are in one place? If so, yes, alot of new Ibanez have dirty pots currently. It's as simple as spinning them 100 times until the dirt cleans off, I have to do every one I find. It's easier and alot less messy that trying to pull the guard and hitting them with cleaner, which only does the same thing in the end.
 

·
Registered
Joined
·
1,093 Posts
Hmm, that sucks, especially on a new (expensive) guitar. Do you have other guitars? If yes, I assume they don't have the problem as you haven't mentioned it?

The first thing this made me think of the issues some Gibsons made in the last 10 years have had with ground/static which was related to the pcb wiring and/or the 'anti-static' plastic covers on the back (derp...). They would act as a capacitor which built up charge in the guitar and resulted in noise/static. I wonder if the pickguard on Pias is not shielded and this is causing a problem?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Hi, yeh I have 7 other guitars (one of them a universe), no problem at all with those. Tried it through both of my amplifiers, different cables, in every electrical outlet in my house, on carpet and tiles, everything to try and rule something out 😕 it's going back to the dealer for one last repair this week
 

·
Registered
Joined
·
815 Posts
Just got my new Pia on Thursday night. Thus far, no crackling noises as described in any way. Will definitely keep an ear open for it as I continue to use it. Just an amazing guitar!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
It went back for a refund in the end. After changing the volume pot for a different type it improved a bit, but the tone pot was still just as bad. They said its a problem with static and that it will always be present to some degree. Took over 6 months to fix and I just got sick of it in the end, probably played it for a total of 10 minutes and it's a shame because it sounded great.
 

·
Registered
Joined
·
124 Posts
Checked out my EVG PIA after reading your post as it hasn't been played for a while> Played on at least 3 amps, no scratchy pots or crackling noise. The only issue I had to get used to is the rough paint job on the inside of the petal grips. But that's about it.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top