Ibanez JEM Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter · #1 ·
Hi All,

Been a while since I posted but I'm really hoping the combined wisdom on here can help me with some tech issues I have been having.

I have recently removed the Backstop device from my Hamer Diablo so the trem (Schaller Floyd) is now fully floating and have added a Tremol-no. A fantastic device!

I am now having problems, however, with the trem returning to pitch properly. I have lubed the posts and knife edges with teflon grease but it as not made much of a difference. Consequently I think the best next course of action is to add locking studs and sharpen the knife edges as per the instructions on Rich's site.

Will the Ibanez edge locking studs fit in the existing Schaller inserts? I think they are an M8 thread so I will most likely need Ibanez inserts as well as the locking posts.

With this in mind, does anyone know the dimensions for the Ibanez inserts (diameter and depth)? I think the Schaller ones are 10mm diameter so if there is any major differences, I will probably buy the parts and then get a luthier to make the mods.

Any advice would be really gratefully received. Google searches aren't bringing up much and I have had a good search through the archives on here this morning.

Cheers

Matt
 

·
Vendor
Joined
·
26,390 Posts
Make sure the T No is at the right alignment and that it is also lubed or it will cause binding and poor return in floating mode.
 

·
Registered
Joined
·
330 Posts
Discussion Starter · #3 ·
Thanks Rich,

I followed the pin type installation video on You Tube so the T-no is working as smooth as I can possibly get it. Also applied some teflon grease to the shaft. I'm pretty sure it isn't the source of the problem as the issue was the same before I installed the T-no.

Cheers
 
1 - 6 of 6 Posts
Top